21

2021 update: the unexpected behavior described below was actual in KDE Plasma v5.18.5, but isn't actual in 5.22.3 anymore.

2023 update: See also this pull request in KDE's GitLab for some details about default browser selection in Plasma 6 (source).


Linux has many ways of "marking" an application "as a default". You can check some of them using following commands:

  1. xdg-settings get default-web-browser
  2. ls -o /etc/alternatives/*browser*
  3. ls -o /usr/bin/*browser* (some of these are symbolic links to the previous list item)
  4. xdg-mime query default x-scheme-handler/https
  5. grep -E 'https|html' /etc/mailcap
  6. If you're on KDE grep BrowserApplication ~/.kde/share/config/kdeglobals

I'm having the exact same issue as in question How do I change the default browser that konsole opens URLs with?.

I'm running KDE 5.13.5. I did following steps:

  1. Uninstall Chromium
  2. Make sure all items listed above point to Firefox.
  3. Go to "System Settings > Applications > Default Applications > Web Browser" (aka $ kcmshell5 componentchooser)
  4. Change setting 'Open http and https URLs' to "in an application based on the contents of the URL"
  5. Click an https link in Konsole
  6. Install Chromium
  7. Click an https link in Konsole

Actual result: after step 5, link is opened in Firefox; after step 7—in Chromium.

Expected result: link is opened in Firefox both in step 5 and in step 7.

So KDE decided, that this particular URL (this one) is better suited (see step 4) for Chromium than for Firefox, despite my efforts to mark Firefox as the default browser in six different ways. If in step 4 I choose "in the following application > Firefox", then everything works as expected, but I want to have it set to "in an application based on the contents of the URL", because sometimes the URLs use schemes different from http and https, e.g. mailto URLs in Konsole need to be opened by the email application, without involvement of a browser.

Which method of marking a browser as default did I miss? How do I convince KDE that this URL is better suited for Firefox, which I tried to mark as my default browser?

P.S. This Debian bugs mail list thread suggests that Konsole does the same as xdg-open <url>, but for me clicking on URL in Konsole opens Chromium, while xdg-open opens Firefox.

5
  • Shot in the dark, but have you tried .config/mimeapps.list - wiki.archlinux.org/index.php/XDG_MIME_Applications?
    – knezi
    Commented Mar 12, 2020 at 10:08
  • 1
    @knezi Firefox has already been set up for http and https there. Now, nine months later on KDE Plasma 5.16.5 I cannot reproduce the issue.
    – andrybak
    Commented Mar 12, 2020 at 21:12
  • I can reproduce this issue in KDE Plasma v5.18.5 in Kubuntu v20.04.2 LTS.
    – Daniel Le
    Commented Jul 17, 2021 at 7:48
  • @DanielLe I can't reproduce in KDE Plasma 5.22.3 (distribution KDE Neon version 5.22). If it had been a bug in Konsole or some other KDE component, then it was fixed. Also the setting "Open http and https URLs" doesn't seem to exist anymore.
    – andrybak
    Commented Jul 17, 2021 at 8:45
  • My issue was that my default browser was set, but when I clicked on an html file, another browser opened. Had to go into settings > applications > file associations to correct the issue. It's very annoying how these things are configured in KDE.
    – Jakke
    Commented Aug 10, 2022 at 14:23

1 Answer 1

3

If you right-click the link and click "save as" then select it wherever you downloaded it, click "open with" and select firefox. there should be a checkbox saying "Remember application association for all files of type "HTML document" (text/html)"

I'm not sure if this will work in the way you need, but it worked for me

3
  • 2
    It seems that you are talking about a right-click menu on a link in a web browser. The question is about links inside the program called Konsole, which isn't a web browser. P.S. please read the 2021 update at the top of the question.
    – andrybak
    Commented Sep 2, 2022 at 20:54
  • In KDE this is actually the only suggestion that worked for handling the panel shortcuts. Commented Oct 6, 2022 at 15:39
  • And in case someone wants a way from terminal: gio mime x-scheme-handler/https to list handlers and e.g. gio mime x-scheme-handler/https org.qutebrowser.qutebrowser.desktop to change the handler.
    – Hi-Angel
    Commented Jul 10, 2023 at 7:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .