4

I've recently installed Pop!_OS and from the very beginning on (even in liveboot) the text I just typed in the terminal, as well as the output wasn't visible for a few seconds and then suddenly appeared. This problem vanished after using the terminal for a few minutes and reappeared after restarting the terminal application. This is certainly not a performance issue, as the delay actually is multiple seconds long, in which the terminal is otherwise still fully functional.

I am using a ThinkPad E485, the following is the output of neofetch:

             /////////////                metacolon@pop-os 
         /////////////////////            ---------------- 
      ///////*767////////////////         OS: Pop!_OS 19.04 x86_64 
    //////7676767676*//////////////       Host: 20KUS02700 ThinkPad E485 
   /////76767//7676767//////////////      Kernel: 5.0.0-15-generic 
  /////767676///*76767///////////////     Uptime: 41 mins 
 ///////767676///76767.///7676*///////    Packages: 1856 (dpkg) 
/////////767676//76767///767676////////   Shell: zsh 5.5.1 
//////////76767676767////76767/////////   Resolution: 1920x1080 
///////////76767676//////7676//////////   DE: GNOME 3.32.1 
////////////,7676,///////767///////////   WM: GNOME Shell 
/////////////*7676///////76////////////   WM Theme: Pop 
///////////////7676////////////////////   Theme: Pop [GTK2/3] 
 ///////////////7676///767////////////    Icons: Pop [GTK2/3] 
  //////////////////////'////////////     Terminal: gnome-terminal 
   //////.7676767676767676767,//////      CPU: AMD Ryzen 5 2500U with Radeon Ve 
    /////767676767676767676767/////       GPU: AMD ATI Radeon Vega Series / Rad 
      ///////////////////////////         Memory: 2632MiB / 7658MiB 
         /////////////////////
             /////////////                                        

Note that I've recently installed zsh and guake, which didn't cause the problem to disappear, but also didn't cause the problem to start, as I never didn't have the problem in Pop!_OS. Also note that I had to adjust the boot parameters, to be able to install Pop!_OS (and every other Linux distribution for that matter), which might have caused the problem. It also might interest you that the problem does not occur in TTYs. I'm not familiar with that kind of stuff though, so I hope that you can help me.


Edit I realized that the text instantly appears if the terminal window loses focus. This is the main reason I can't provide a screenshot for this question.


Edit Whilst installing a system update, I got the following warning:

update-initramfs: Generating /boot/initrd.img-5.0.0-15-generic
cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries 
    nor crypto modules. If that's on purpose, you may want to uninstall the 
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs 
    integration and avoid this warning.
W: Possible missing firmware /lib/firmware/amdgpu/vega20_ta.bin for module amdgpu
kernelstub.Config    : INFO     Looking for configuration...
kernelstub           : INFO     System information: 

    OS:..................Pop!_OS 19.04
    Root partition:....../dev/nvme0n1p3
    Root FS UUID:........df269b39-4b92-4870-8f80-db4d2df9c762
    ESP Path:............/boot/efi
    ESP Partition:......./dev/nvme0n1p1
    ESP Partition #:.....1
    NVRAM entry #:.......-1
    Boot Variable #:.....0000
    Kernel Boot Options:.quiet loglevel=0 systemd.show_status=false splash ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1
    Kernel Image Path:.../vmlinuz
    Initrd Image Path:.../initrd.img
    Force-overwrite:.....False

I don't know if it's relevant, but maybe it helps finding a solution for my problem - which by the way didn't disappear after installing the update.


Edit As is visible in the warning I got, my current boot parameters are:

quiet loglevel=0 systemd.show_status=false splash ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1

I suspect that either this or the bios provided by Lenovo causes the issue.


Edit I realized the problem is not limited to my terminal (it's the most annoying there though), as I've also experienced a similar issue in the GNOME calculator.

  • The warning message is completely unrelated to your issue. – rage Jun 26 '19 at 20:07
1
+50

Your symptom sounds similar a problem I had with xfce4-terminal in an xrdp Xvnc session on CentOS 7. My research now leads me to this option: Perhaps you could adjust your DE's font subpixel settings to anything other than "None." Source: https://bbs.archlinux.org/viewtopic.php?id=245284

For reference, in the Xfce Settings Manager -> Appearance application: Font tab in Appearance settings window

For GNOME Shell, it will be in gnome-tweak-tool: https://askbot.fedoraproject.org/en/question/64130/how-to-improve-font-rendering-in-gnome-shell/

  1. Install freetype-freeworld (if not already bundled into libfreetype6; exact package name in Pop!_OS is not available to me)
  2. Adjust hinting and subpixel order in gnome-tweak-tool

Or use gsettings

gsettings "set" "org.gnome.settings-daemon.plugins.xsettings" "hinting" "slight"
gsettings "set" "org.gnome.settings-daemon.plugins.xsettings" "antialiasing" "rgba"
|improve this answer|||||
  • This method seems to work, thanks! I'll test it for another day and if the problem won't come back, you'll receive your well earned bounty. – MetaColon Jun 28 '19 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.