0

I was trying to upgrade a system but I was getting a,

You don't have enough free space in /var/cache/apt/archives/.

I tried to apt-get autoremove, apt-get clean and still nothing.

There is no space left at root:

http://prntscr.com/o20ccl

And then read somewhere that, installing libapt-pkg5.0 manually that this issue could be fixed, so I tried to install but there was some missing dependencies and it stops, then I notice that I was no longer able to use apt anymore.

I have also reboot this system, but the problem persists. I have also run sudo ldconfig, but same result.

Do you know how can I solve this?

If you need more info do help feel free to ask.

0

Seems like I have installed a non compatible libapt-pkg5.0 for my debian 9 so I just downloaded the right version of that lib,

wget http://ftp.br.debian.org/debian/pool/main/a/apt/libapt-pkg5.0_1.4.9_amd64.deb

and install it through,

dpkg -i dpkg -i libapt-pkg5.0_1.4.9_amd64.deb

and it came back to live again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.