1

I'm trying to get my desktop configured to have wake-on-wireless-LAN working. I've turned it on with:

> sudo iw phy0 wowlan enable magic-packet

and I can confirm that it's enabled:

> iw phy phy0 wowlan show
WoWLAN is enabled:
 * wake up on magic packet

However, the problem now is that the computer will not sleep at all. If I hit suspend from the Gnome Launcher, or run sudo pm-suspend, it goes to sleep and then immediately wakes up. It seems like there's some "false positive" triggering the Wake-On-Lan.

I can confirm that with wowlan disabled, the behaviour does not happen.

I'm wondering:

  • Is this a known issue?
  • How can I determine what's causing the wake to be immediately triggered?
  • Is there a way to fix it?

lspci reveals that my network adapter is Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter. I'm on Ubuntu 19.04. The card itself is a TP-Link Archer T4E.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.