0

We are doing a:

vi /etc/systemd/system/cpupower.service

[Unit]
Description=CPU powersave

[Service]
Type=oneshot
ExecStart=/usr/bin/cpupower idle-set -D 0
ExecStart=/usr/bin/cpupower frequency-set -g performance

[Install]
WantedBy=multi-user.target

and:

chmod 644 /etc/systemd/system/cpupower.service; systemctl enable cpupower.service

on SLES12.3 machines, but after reboot this doesn't sets them!

It will only get set if we do a "systemctl restart cpupower.service" manually..

The Question: how to make it permanent, so it will be set after every reboot?

0
sed -i.$(date +%F-%Hh-%Mm-%Ss) 's/#governor/governor/g; s/#energy_perf_bias/energy_perf_bias/g; s/#min_perf_pct/min_perf_pct/g' /usr/lib/tuned/*/tuned.conf

tuned helped! (off: it should be modified in /etc/, not in /usr, since a tuned update could remove the setting)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.