1

I dual boot my machine by shrinking the size of partition and creating un-allocated space through windows 7 and at that un-allocated space I installed ubuntu after the complete installation of Ubuntu 18.04 I restart my laptop than the GRUB boot menu showed up. But there was only option for booting Ubuntu not the windows7.

enter image description here

Although all windows partitions can be accessed through ubuntu but at the starting no option is showing for booting window in the GRUB boot menu. I tried to rectify this error by using command:

sudo update-grub

But that did not work well. I run the following command as well:

sudo fdisk -l

enter image description here

the result is shown in which all the partitions are available

So, kindly provide me with the solution of that problem.

  • Looks like you moved your boot partition /sda1 , and bad things are known to happen if you do. The boot partition normally starts near the beginning of the drive, but it's now after the end of /sda2 .Suggest you make a disk-to-disk copy of that drive with Clonezilla clonezilla.org to a disk at least 554GB in size before trying to resolve this, if you did not have a complete backup before you started. – K7AAY Jun 12 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.