1

HDD; debian OS; orangepi; 2TB; (SCSI DISK) (WDC WD20 03FZEX-00SRLAO) ......................

I am trying to mount my 2TB WD hdd. as "mount rw, /dev/sda1 exthdd; mount -o rw /dev/sda1 /media. lsblk: disk recognized. DMESG | TAIL : couldn't mount RDWR b/c of unsupported optional features (400)

"Failed to mount "exthdd". Error mounting /dev/sda1 at media/username/exthdd: command line 'mount -t "ext4" -o uhelper=udisks 2,no dev,nosuid "/dev/sda1" "media/username/exthdd - exited with non-zero exit status32: ; "mount: wrong fstype, bad options, etc etc etc........other"

*****After reading the 'similar' article, I tried the following: "turn it off on an already created filesystem" "sudo tune2fs -O ^metadata_csum /dev/sdb1"

Did not work. The aforementioned article talks about an SD CARD, my media is a hdd.

Not able to mount either "ro,noexec" or "rw" on my desktop computer where the hdd was formatted. I was able to mount it to a laptop w/ ubuntu, but was not able to copy, paste, or create a folder as "permission denied". I think this hdd was specifically formatted to be solely used with my username for this desktop, debian OS, computer.

I see to format external media, do the following... You'll see where it says "chown" that it asks for my username. I'm wondering if I can do something to remove my username from the hdd (if it's on there) so it will work on other systems.....??????

Thanks.

  • mounting: "mount -o ro,noexec /dev/sda1 /exthdd; mount -o ro,noexec /dev/sda1 /media; mount -o rw /dev/sda1 /exthdd; mount -o rw /dev/sda1 /media – sgu55 Jun 12 '19 at 6:28
  • Thanks. Which would you recommend? Which would least likely, if either, to cause a potential problem with the files? To create a ext4 filesystem without this feature: sudo mke2fs /dev/sdb1 -O ^metadata_csum Or turn it off on an already created filesystem: sudo tune2fs -O ^metadata_csum /dev/sdb1 I think I already have a filesystem, so I am thinking option 2. Thx. – sgu55 Jun 12 '19 at 6:53
  • 1
    Yes, you already have a filesystem that uses a feature that is too new for the OS version on your OrangePI. You'll have to take the disk back to the system that created it, switch that feature off, and then try again mounting it with your OrangePI. Using mke2fs would definitely destroy any existing files. – telcoM Jun 12 '19 at 7:36
  • I tried this, didn't work: sudo tune2fs -O ^metadata_csum /dev/sdb1; I changed sdb1 to my sda1. I also tried the exthdd on ubuntu on a laptop. The laptop didn't find it - nothing in lsblk. – sgu55 Jun 12 '19 at 9:24
  • Since lsblk is not showing the disk, check dmesg for related errors. – Emmanuel Rosa Jun 12 '19 at 10:30

Browse other questions tagged or ask your own question.