6

I am new to Manjaro and Arch. Recently I started running into an issue that I don't know how to solve.

The Issue

The chromium and skypeforlinux windows freeze, but the apps keep running. For example skype calls don't break off but the window is stuck. Same with chrome and chromium. If I am chatting (say telegram web) and the issue happens I can still send messages, but the screen does not update. So I am acting 'blindly'. Other Apps like Emacs (also installed with yay), Telegram (yay) or terminal (native urxvt) are uneffected.

Another symptom: When I have Emacs running on Screen 1 and a broken Chrome on Screen 2, and when I switch from 1 to 2, then the window continues to show the contents of Screen 1, in this case emacs.

What is happening?

My system:

Manjaro Architect (uname -a): Linux archangel 5.1.4-1-MANJARO #1 SMP PREEMPT Wed May 22 17:56:21 UTC 2019 x86_64 GNU/Linux

pacman --version: Pacman v5.1.3 - libalpm v11.0.3

i3 --version: i3 version 4.16.1 (2019-01-27)

yay --version: yay v9.2.0 - libalpm v11.0.3

Effected apps (installed with yay/pacman):

skypeforlinux: skypeforlinux-preview-bin 8.47.76.58-1

chromium --version: Chromium 75.0.3770.80 Manjaro Linux

6
  • edit: shortended the question and fixed typo Jun 13, 2019 at 13:51
  • the issue arose for the first time after running a recent systemupgrade (pacman -Syyuu) Jun 13, 2019 at 14:55
  • when running chromium with from cli I get many [31987:31987:0614/074925.816172:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote errors when the issue occurs Jun 14, 2019 at 5:54
  • Just use web.skype.com if you must use Skype, no binaries needed.
    – Dagelf
    Jun 14, 2019 at 14:16
  • chromium is the bigger problem. Jun 14, 2019 at 18:06

1 Answer 1

5

I recently had the same issue. In my case, the problem was solved by forcing DRI 2 instead of DRI 3 (I have an intel graphic card with the intel drivers).

I basically followed the instructions given here:

https://wiki.archlinux.org/index.php/Intel_Graphics#DRI3_issues

In a nutshell, I had to write

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "DRI" "2"
EndSection

in /etc/X11/xorg.conf.d/20-intel.conf

I hope this helps!

3
  • 1
    Seems to have worked for me. I was unable to use linux kernel >= 4.20 for a significant period of time without losing windows, but after applying this config the behavior has not repeated.
    – billkw
    Jan 25, 2020 at 18:06
  • Can somebody tell me how to adapt this to also work with the proprietary NVidia drivers? My vscode freezes for 1-2 seconds the again and again. The only solution I found is to start code with --disable-gpu.
    – al-bex
    May 21, 2020 at 19:54
  • Using DRI 2 breaks Vulkan support for me
    – jojman
    Oct 4, 2020 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .