2

I've made a clean installation of Devuan ASCII and upgraded to Beowulf. I've logged in to Cinnamon, and things seem fine - except for controlling audio:

  • There is no mixer up in the Start Menu by default
  • If you install alsamixergui - it does nothing (not even complain)
  • If you instead pavucontrol- you'll get the PusleAduio Volumne Control entry; but it will only tell you "Establishing connection to PulseAudio".
  • If you manually start pulseaudio in a terminal - pavucontrol will work, but that's no way of doing things... also, it will show a "dummy" output device.
  • When starting pulseaudio manually, it says:

    E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.
    AccessDenied: Rejected send message, 2 matched rules; type="method_call",  sender=
    ":1.121" (uid=1000 pid=9019 comm="pulseaudio ") interface="org.freedesktop.DBus.
    ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" 
    destination="org.bluez" (uid=0 pid=1972 comm="/usr/sbin/bluetoothd ")
    
  • No volume control widget/applet on the taskbar

My question:

  1. Is this my fault for not having installed something critical?
  2. What can I do to resolve/circumnavigate around these this;
1

Seems that you have two problems here

  1. Something is wrong with your config

    1.1. Sound card is not recognized

  • If you install alsamixergui - it does nothing (not even complain)
  • If you manually start pulseaudio in a terminal - pavucontrol will work, but that's no way of doing things... also, it will show a "dummy" output device.

Seems that your sound card is not properly configured. Probably missing kernel modules. Search for "Alsa sound card not detected".

This is the firts problem to fix. Once fixed use alsamixer to check that sound card is working properly.

1.2. Access to bluetooth devices not allowed

E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.
AccessDenied: Rejected send message, 2 matched rules; type="method_call",  sender=
":1.121" (uid=1000 pid=9019 comm="pulseaudio ") interface="org.freedesktop.DBus.
ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" 
destination="org.bluez" (uid=0 pid=1972 comm="/usr/sbin/bluetoothd ")

Seems that access to bluetooth is denied for your user. Are your user member of bluetooth group?

  1. Pulseaudio is not started automatically

To fix this edit /etc/pulse/client.conf.d/00-disable-autospawn.conf and comment the line:

autospawn=no

See https://bugs.devuan.org//cgi/bugreport.cgi?bug=318

Hope this helps

  • How is the link related to my issue? – einpoklum - reinstate Monica Oct 5 at 19:20
  • This solved the problem in my computer. Upgrading from ascii to beowulf (xfce). In my case 00-disable-autospawn.conf setting prevented pulseaudio to run before Xsession on non systemd systems. – Pelayo González Oct 7 at 7:45
  • You mean, when you did this, and started PulseAudio manually, you stopped getting the error message? – einpoklum - reinstate Monica Oct 7 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.