2

I'm running MacOS Mojave 10.14.2 with Homebrew and MacPorts installed; I'm attempting to install the dsniff suite via the command line, and I installed Xcode's command line tools for this purpose--I also have Xcode 10.1.

Whenever I run sudo port and install dsniff, I get in return:

Error: Failed to configure dsniff, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/work/dsniff-2.4/config.log Error: Failed to configure dsniff: configure failure: command execution failed Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff/dsniff/main.log for details. Error: Follow https://guide.macports.org/#project.tickets to report a bug. Error: Processing of port dsniff failed

I get the same error messages when running install dsniff -devel as well.

After having read around online for solutions and interpreting the log provided, I tried the installation with Brew.

I ran brew install berkeley-db libnet libnids libpcap openssl and all of the dependencies were either updated or installed. The primary problem I'm encountering is in attempting to configure the paths for the dependencies.

Whenever I try to run ./configure /followed by the configure script, I get $ ./configure: No such file or directory:

--with-libpcap=/usr/local/opt/libpcap \

--with-openssl=/usr/local/opt/openssl \

--with-libnet=/usr/local/opt/libnet \

 --with-libnids=/usr/local/opt/libnids \

 --without-x

I'm at a loss for how to proceed.

  • 1
    Afaik dsniff scripts and code base are too old. I have not been able to compile it either. It should be removed from macports. – Rui F Ribeiro Jun 13 '19 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.