28

Each time, if I want to use the terminal, I press the super key, type "terminal" in the search box, and enter to select the terminal icon.

How can I have a hotkey to open the terminal. (I do not say hotkey: control + alt + Fn because it will open a full-console, not what I want). I just want a terminal window.

I have searched all keyboard shortcuts but I don't see any option to select a hotkey for this purpose. I just see only one option: "Hotkey to enter the command". When using this hotkey, it will appear a small popup, but I don't know what command exists. (and it doesn't look like terminal)

1 Answer 1

39

Open System Settings

  • select Keyboard,
  • select Shortcuts Tab,
  • the last item is 'Custom Shortcuts'
  • press [+]

  • enter Name: Terminal

  • into Command: enter 'gnome-terminal' (without quotes)
  • press Apply
  • click in the newly created line on 'Disabled'
  • press key combination which you want to use for terminal (e.g. Alt-Home).

You're set.

6
  • Thanks :) I don't know this console can call by 'gnome-terminal'. But other question, why all hotkey is allow, but when I define : super + R. It won't work. do you know why ?
    – hqt
    Commented Oct 20, 2012 at 14:34
  • There are many other terminals available for linux, so it does not have to be gnome-terminal, but it can be xterm,aterm etc. Not sure why Super-R does not work, but I can confirm it does not work for me neither.
    – Crash
    Commented Oct 20, 2012 at 14:40
  • Crash, @hqt what desktop you are using? I succeeded to assign and use super+R with XFCE
    – Serge
    Commented Oct 22, 2012 at 3:18
  • For Fedora 20, it's also necessary to mention that you have to click the "Disabled" word to allow it to let you specify a keyboard shortcut.
    – Nav
    Commented Jan 15, 2014 at 7:45
  • To specify the size, you can use this advice: gnome-terminal --profile=Default --geometry=95x35+250+60 Commented Jun 10, 2015 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .