I am running Debian stretch (9.9) and I can't dist-upgrade. I have no held packages.
My version and kernel:
lsb_release -a No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 9.9 (stretch) Release: 9.9 Codename: stretch uname -a beastmode 4.17.0-0.bpo.1-amd64 #1 SMP Debian 4.17.8-1~bpo9+1 (2018-07-23) x86_64 GNU/Linux
My apt-mark showhold command shows no held packages.
me@pc:~$ sudo apt-mark showhold me@pc:~$ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Error! Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libkf5su-bin : Depends: libkf5su5 (>= 4.96.0) but it is not going to be installed monodoc-browser : Depends: libwebkit1.1-cil (>= 0.3) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
The broken package from KDE (libkf5su-bin) can be removed, but monodoc-browser is NOT EVEN INSTALLED and I didn't ask for it to be installed.
What do I do to repair my system?
(Update: I think I need to remove anything installed that appears in the list, and add anything that isn't installed yet, that appears in the list of brokenness. )
(Update: Third party repos are a huge source of pain! )