I am running Debian stretch (9.9) and I can't dist-upgrade. I have no held packages.

My version and kernel:

lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.9 (stretch)
Release:    9.9
Codename:   stretch

uname -a

beastmode 4.17.0-0.bpo.1-amd64 #1 SMP Debian 4.17.8-1~bpo9+1 (2018-07-23) x86_64 GNU/Linux

My apt-mark showhold command shows no held packages.

me@pc:~$ sudo apt-mark showhold
me@pc:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libkf5su-bin : Depends: libkf5su5 (>= 4.96.0) but it is not going to be installed
 monodoc-browser : Depends: libwebkit1.1-cil (>= 0.3) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The broken package from KDE (libkf5su-bin) can be removed, but monodoc-browser is NOT EVEN INSTALLED and I didn't ask for it to be installed.

What do I do to repair my system?

(Update: I think I need to remove anything installed that appears in the list, and add anything that isn't installed yet, that appears in the list of brokenness. )

(Update: Third party repos are a huge source of pain! )

  • 1
    What is the contents of your sources.list?
    – kemotep
    Jun 10, 2019 at 19:44
  • 1
    Have you run apt-get update to refresh the local package list? Jun 10, 2019 at 19:46
  • @WarrenP You should also note that you are on the latest release of Debian 9 so running apt-get dist-upgrade should not install anything if you are up to date new unless your sources.list has non-stretch (stable) repos.
    – kemotep
    Jun 11, 2019 at 2:18
  • Could you show the output of apt policy? Do you have a reference to Microsoft’s repositories by any chance? They are currently breaking KDE, apparently. Jun 11, 2019 at 4:11
  • 1
    @WarrenP please consider moving your answer out of the question and into an answer and accepting. Thank you!
    – kemotep
    Jun 11, 2019 at 15:41

1 Answer 1


The following steps were needed:

  1. remove third party sources that may have bad dependencies (MS VS CODE and SKYPE repos)

  2. Remove installed items that came up in the error list.

  3. INSTALL the items that came up in the error list as bad dependencies, but which were not installed.

Afterwards having completely uninstalled KDE (which seems to have been broken by the MS REPO), I had to reinstall KDE or some other desktop. I decided to switch to Mate instead of reinstalling KDE.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .