0

RHEL 7.6, managing an offline system with the updates from an identical online system. I have a local repository created on the offline system and doing a yum update has worked fine... until.

.
.
.
Found and removing 0 unneeded dependencies

Error: Package: libkadm5-1.15.1.1-34.el7.x86_64 (@dvd)
    Requires: krb5-libs(x86-64) = 1.15.1-34.el7
    Removing: krb5-libs-1.15.1-34.el7.x86_64 (@anaconda/7.6)
       krb5-libs(x86-64) = 1.15.1-34.el7
    Updated by: krb5-libs-1.15.1-37.el7_6.x86_64 (local)
       krb5-libs(x86-64) = 1.15.1-37.el7_6

I also get the same error...

  • regarding krb5-devel-1.15.1-37.el7_6.x86_64
  • requires 1.15.1-34.el7
  • removing 1.15.1-34.el7
  • updated by 1.15.1-37.el7_6

And for openssl-devel but with different version numbers. What I do not understand is how this could have come about where anything done on this offline system has been done successfully on the online system. So why this problem with versions, and how can it be corrected?

1

You have a package, libkadm5, that requires a specific version of krb5-libs (krb5-libs(x86-64) = 1.15.1-34.el7).

You are running an update process that would like to update krb5-libs to version 1.15.1-37.el7_6, but that would break the package libkadm5 due to no longer having the exact version of krb5-libs it wants. The update was not performed as it could not resolve that dependency conflict.

The proper resolution would be to make sure you have libkadm5-1.15.1-37.el7_6 available in your YUM repositories (should be located in the updates repository of EL 7.6). That should allow the krb5-libs package to update cleanly.

As to why this happened, I am not certain but it may have to with the versioning of the package in question. Looking closer at the package you are having an issue with, libkadm5-1.15.1.1-34.el7.x86_64, compared with the package you need, libkadm5-1.15.1-37.el7_6, you will see the conflicting package has an extra .1 in the version which could be throwing off YUM's update algorithms (i.e. YUM could not determine that libkadm5-1.15.1-37.el7_6 was a higher version then libkadm5-1.15.1.1-34.el7.x86_64 due that that .1, and so it was not selected for update). If this is the case, you may have to resolve the issue manually by removing libkadm5-1.15.1.1-34.el7.x86_64 and replacing with libkadm5-1.15.1-37.el7_6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.