0

This question already has an answer here:

I am a user of Fedora 30. I installed Fedora on a USB memory stick and use it with Windows 10 on the same computer. How do I set the options in fstab to make it read-write to an NTFS-formatted Windows 10(hdd 01) or secondary disk(hdd 02)?

marked as duplicate by Rui F Ribeiro, Gilles, roaima, Yurij Goncharuk, slm Jun 10 at 0:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

By default, Windows 10 uses a technique called Fast Startup, which starts the system by loading a prepared hibernation RAM image of a freshly-rebooted system instead of starting the various Windows components one by one.

This is fine if Windows is the only operating system, but when you are dual-booting another operating system, the use of Fast Startup makes the filesystems look like Windows has been hibernated. At that point, the other operating system must assume that the hibernation file might include some disk I/O buffers that have not yet been written to the filesystem properly, and so the filesystem might be in an inconsistent state until Windows starts up again and writes those buffers out.

Before that happens, the other operating system must not be allowed to mount the NTFS filesystems in read/write mode, as there would be no way to reflect any changes made by the other operating system into the data in the I/O buffers in the hibernation file. After making any changes, the data in the hibernated buffers would be stale and might cause severe NTFS filesystem corruption.

So, in order to be able to mount the Windows NTFS filesystems in Linux, you must first disable Windows Fast Startup. To do that, boot into Windows, open the Command Prompt as Administrator, and then run this command:

powercfg /h off

After this, back in Linux, you can use lsblk --fs or blkid to identify the UUIDs of your Windows partitions/filesystems, and then construct /etc/fstab entries like this for them:

UUID="<NTFS UUID here>" <desired mountpoint here> ntfs-3g defaults,windows_names,inherit,nofail 0 0
  • Thans alot! it is a very useful advice. – unmask Jun 14 at 19:56
0

You shouldn't need to modify fstab to access the drives, just navigate to them in your file manager (Nautilus?) and it should mount them.

If you can't do this already, then you probably need to install the ntfs-3g package.

Not the answer you're looking for? Browse other questions tagged or ask your own question.