0

I have an old PC and its HDD isn't working so I installed elementary OS in my External HDD and tried to boot from it but my PC returned a grub rescue "no such partition" error.

I tried to boot from it through my laptop and it worked fine. I tried typing ls finding the partition manually but strangely it listed only one partition but it real has 1 NTFS, 1 ext4, 1 swap. Is this because my PC is failing to detect the entire 1 TB drive, if so any work around (Without formatting the NTFS partition is preferred)?

I have attached the partition table of the External HDD:Partition table GParted [Grub rescue] (https://i.stack.imgur.com/bmlcp.jpg)

  • What makes you think the whole 1TB isn't recognized? I don't know your issue, but variations in BIOS/UEFI can cause one machine to boot an external drive correctly, another to not boot it (was your OS installed on your desktop? or the laptop? did you use UUID [ie. drive specific] or sdax labelling (ie. bios/config specific or machine specific) – guiverc Jun 8 at 4:01
  • I have added the grub rescue screen which made me think so – amal amas Jun 8 at 4:16
  • Sorry I'm confused; you have mentioned two machines, and not answered on which you installed elementary (except it was the external drive). Many machines BIOS/UEFI can ignore external drives for booting (they aren't seen, or for some they'll see one external device if only one installed, but if more than one ignore them all during booting; some of this can be changed in machine setup), so it could be limitations of your hardware (or having multiple usb devices plugged in during boot due to BIOS limitations). You'll have to provide more, or check you machines bios/config setup. – guiverc Jun 8 at 4:29
  • I installed elementary using the same system but had a different motherboard hence different BIOS but it had worked on most system I had used it on. I will try installing it using the current system. I don't think it is the motherboard failing to recognize the USB as it did boot from the live Ubuntu USB while I had plugged both of them in more over it could load the grub from external HDD. – amal amas Jun 8 at 14:35
  • It doesn't matter if the motherboard recognizes the USB drive, there is no single standard for the order devices are recognized, and one make/model (inc. motherboard) can treat the order differently, or a sda drive can become sdb etc so any references like that will be wrong (thus you can't get past grub; esp. a problem with external/usb drives). The use of UUIDs should void this as they are drive specific unique IDs (but no guarantee as external is controlled by bios/uefi settings too) – guiverc Jun 8 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.