I'm trying to use debootstrap to create a debian32 system and compile the kernel there but I'm not capable off.

root@citsnmaiko-deb:~# debootstrap  --verbose --arch i386 squeeze /opt/chroots/debian32/ http://ftp.debian.org/debian/
I: Retrieving Release
E: Failed getting release file http://ftp.debian.org/debian/dists/squeeze/Release

I'm behind a proxy but apt-get and wget works fine, I already tryied to set the http_proxy var but without success.

what else can I do ?

  • You mention that apt-get works fine. Is ftp.debian.org the mirror you are using in your sources.list? Are you perhaps using ftp instead of http?
    – Zoredache
    Oct 19, 2012 at 19:31

2 Answers 2


You're using the right command. Your question appears to be just "what else can I do ?" (sic).

So here are a few reasons why this might happen.

  • Unreachability of ftp.debian.org from your machine
  • Unexplained error on ftp.debian.org

Can you:

  • resolve the name?
  • successfully make a tcp connection to it on port 80?
  • retreive that file?

Try using nc or curl to pull the file. Run tcpdump in another terminal and see what happens.

  • I changed the mirror and export my http_proxy. Now its working. Thx
    – MaikoID
    Oct 22, 2012 at 18:06

Lets help someone with Google foo. Same error but different cause

root@vm-lucid:/tmp/ramfs# debootstrap lucid here http://old-releases.ubuntu.com/ubuntu/
I: Retrieving Release
E: Failed getting release file http://old-releases.ubuntu.com/ubuntu/dists/lucid/Release

Typical debug step, proves network / proxy / mirror is okay... so now what?

wget http://old-releases.ubuntu.com/ubuntu/dists/lucid/Release

Adding set -x to just_get in /usr/share/debootstrap/functions and logging via if ! just_get "$from" "$dest2" > /tmp/debootstrap_hidden_log 2>&1; then continue; fi reveals something interesting!

+ set -x
+ local from=http://old-releases.ubuntu.com/ubuntu/dists/lucid/Release
+ wget -q -O /tmp/ramfs/here/var/lib/apt/lists/partial/debootstrap.invalid_dists_lucid_Release http://old-releases.ubuntu.com/ubuntu/dists/lucid/Release
Can't be verbose and quiet at the same time.
Usage: wget [OPTION]... [URL]...
+ ret=1

Why would one get that error message???

SOLUTION: Remove verbose=on from wgetrc, that a user forgot in there years ago...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .