I tried to install KiCad after i updated my Debian box to Debian 10, but i got the following error.
The following packages have unmet dependencies: kicad : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed Recommends: kicad-libraries but it is not going to be installed Recommends: kicad-doc-en but it is not going to be installed E: Unable to correct problems, you have held broken packages.
After that i did
sudo apt update and ran
apt-cache policy libc6 and got the following result.
libc6: Installed: 2.28-10 Candidate: 2.28-10 Version table: *** 2.28-10 500 500 http://ftp.au.debian.org/debian buster/main amd64 Packages 100 /var/lib/dpkg/status 2.24-11+deb9u4 500 500 http://deb.debian.org/debian stretch/main amd64 Packages 2.24-11+deb9u1 500 500 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages 500 http://security.debian.org stretch/updates/main amd64 Packages
So my question is how to i update libc6 from 2.28 to 2.29 so i can install KiCad, beacuse whenever i run
sudo apt upgrade libc6 i always get
Reading package lists... Done Building dependency tree Reading state information... Done libc6 is already the newest version (2.28-10). Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.