I tried to install KiCad after i updated my Debian box to Debian 10, but i got the following error.

The following packages have unmet dependencies:
kicad : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed
         Recommends: kicad-libraries but it is not going to be installed
         Recommends: kicad-doc-en but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After that i did sudo apt update and ran apt-cache policy libc6 and got the following result.

  Installed: 2.28-10
  Candidate: 2.28-10
  Version table:
 *** 2.28-10 500
        500 http://ftp.au.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
     2.24-11+deb9u4 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
     2.24-11+deb9u1 500
        500 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages
        500 http://security.debian.org stretch/updates/main amd64 Packages

So my question is how to i update libc6 from 2.28 to 2.29 so i can install KiCad, beacuse whenever i run sudo apt upgrade libc6 i always get

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version (2.28-10).
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • 2
    Where did you get your KiCad package? It’s available in Debian and installs fine from the Debian repositories. Commented Jun 7, 2019 at 4:19

1 Answer 1


Installing it on Stretch works with no issues as it depends on libc6 2.24 which is the latest available for Stretch.

libc6 2.28.10 is the latest version of libc6 available for Buster. The only way to get 2.29 is to compile it from source and prepend the libraries to your LD_LIBRARY_PATH. You can get it here: https://www.gnu.org/software/libc/sources.html and then get KiCad from github: https://github.com/KiCad/kicad-packages3D/releases

You can also build an older version of KiCad from source via that same link that depends on libc6 2.28.

Keep in mind that the first method will most likely cause other things not to work properly because the system is very particular about having the right version of libc6 installed. If you plan to compile it and prepend the libraries, make sure that you are doing it as a user with no sudo rights and not as root.

Lastly, Buster is not yet released and is, as of now, unsupported. It's possible that libc6 2.29 will be released in the future for the kicad from the Debian repos.

  • Re your last point, Buster will release with glibc 2.28. Commented Jun 18, 2019 at 16:12
  • @StephenKitt Right, but the kiCad that he's trying to install requires glibc 2.29. Commented Jun 18, 2019 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .