1

I finally found out how to make my Pop!_OS recognize my HDMI for audio. (basically I'm using an ASUS laptop with a 1060 hooked with a monitor, everything was fine except for the HDMI audio output not displaying on the audio output list)

I followed this guide and it works flawlessly, but every time I reboot my machine I have to run this commands in order for the fix to apply again..

sudo modprobe nvhda
sudo tee /proc/acpi/nvhda <<<ON

I originally extracted the zip file on my downloads folder and followed the steps from there on, I'm aware I can now skip the make and install part and just just straight use the sudo modprobe nvhda to load the fix; I don't know if I can already delete that extracted folder (or should I move it to root folder/other..).

That's a separate question basically, but main question is how would I make a script that executes those 2 pieces of code on system start/boot.

1

You can delete the folder if you installed the module with sudo make install.

See https://bugs.freedesktop.org/show_bug.cgi?id=75985#c33:

I can confirm that kernel module, posted by Maik Freudenberg [Comment 27], is working fine on my system. Thank you for the fix. The HDMI audio device now works as it should.

The steps I did to enable HDMI audio device:

  1. Download and extract the file nvhda.tar.xz.
  2. Run commands in terminal:

    make
    sudo make install
    echo nvhda | sudo tee -a /etc/initramfs-tools/modules
    echo "options nvhda load_state=1" | sudo tee /etc/modprobe.d/nvhda.conf
    sudo update-initramfs -u
    
  3. Reboot.

With this fix, I did not notice any problems with power management or system stability. HDMI audio works at system startup, after resume from sleep, after plugging/unplugging HDMI cable.

No need to write an extra script.

Related: Nvidia NVHDA Non-Detected Workaround and Suspend Fix for NVHDA (ubuntuforums)

  • Thanks a lot, I'm pretty sure that guy is using the same laptop model as me; this has solved my issue. – Derivates Jun 7 at 4:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.