2

In the last 2 months, I have installed Linux Mint 19.1 on two laptops. On the older of the two, a Samsung Rv511 (ca. 2011) using MBR partitioning, there have been no problems at all. Linux Mint has worked very well.

With a 2018 HP Pavilion with UEFI and GPT partitioning, the reverse has been true. Linux Mint crashed after 2 weeks of use. Thereafter, the laptop would boot, show the small Mint icon then go to the Grub 2 menu. At the root prompt, I changed the boot order placing the USB stick first. This enabled me to boot from the USB stick and reinstall Mint. Yesterday, Mint crashed again. This was preceded by a warning message that the update manager was not working (coincidental?).

Legacy support and Secure boot were disabled on both occasions. The HDD was partitioned with primary partitions for root (/), eti, boot/grub, home and swap. From what I've checked out online, it seems that the boot/grub partition is not necessary on a UEFI machine. However, not having a boot/grub partition leads to the installation process hanging immediately after the partitions have been defined. I'm at a loss as to what to do next.

EDIT: The laptop is an HP 15-cs0057tx Sorry for my inexact terms, by "crashed" I meant not booting. The boot/grub folder was not included among the partition definitions. The result was that the installation process froze immediately after the continue button was clicked.

I kept an edited copy of the log file at the time of the first booting failure. Below is a heavily edited version. The starred lines are error messages (hilited in red in the log file). The other lines are hilited white comment lines.

Linux version 4.15.0-48-generic (buildd@lgw01-amd64-036) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #51-Ubuntu SMP Apr 3 08:28:49 UTC 2019 (Ubuntu 4.15.0-48.51-generic 4.15.18)
...
Secureboot could not be determined (mode 0)
...    
Kernel command line: Boot_Image=/boot/vmlinuz-4.15.0-generic root=UUID=60980aba-8d360-4i43-ba01-56b7fa029850 ro quiet splash
...    
ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
...    
VFS: Disk quotas dquote_6.6.0
...    
Initialise system trusted keyrings
Assymetric key parser '509' registered
...    
Key type dns_resolver registered
...    
Loaded compiled-in X.509 certificates
Loaded X.509 cert 'Build time autogenerated kernel key: e70.....707
Loaded UEFI:db cert 'Microsoft Windows Production PCA 2011: a92.....f53' linked to secondary sys keyring
Loaded UEFI:db cert 'Microsoft Corporation UEFI CA 2011: 13a.....bd4' linked to secondary sys keyring
Loaded UEFI:db cert 'Hewlett-Packard Company: HP UEFI Secure Boot 2013 DB key: 1d7.....bec' linked to secondary sys keyring
*Couldn't get size: 0x800000000000000e
...    
*sd 1:0:0:0 [sdb] No Caching Mode page found
*sd 1:0:0:0 [sdb] Assuming drive cache: write through
...    
*PKCS#7 signature not signed with trusted key 
nvidia: loading out-of-tree module taints kernel.
nvidia: module license 'NVIDIA' taints kernel.
Disabling lock debugging due to kernel taint
nvidia: module verification failed: signature and/or required key missing - tainting kernel
...    
*fsck failed with with exit status 4.
...    
*Failed to start File System Check on /dev/disk/by-uuid/2ad686b0-e77b-47da-bb44-5934b5fa6541.

Thank you for your interest.

EDIT: I overrode the Mint 19.1 default swap file (from ignorance actually, I was not aware that Mint 19.1 created its own swap file. I've been using Ubuntu for years). The partitions were not encrypted.

  • 1
    Could you clarify a couple of things in your question. When you say "crashed" do you mean "will not boot" or do you mean "frozen while in use"?. When you say does not need a /boot/grub partition, do you mean "it's own partition" or do you mean the folder is not needed? Please edit your question to clarify. – Philip Couling Jun 6 '19 at 12:55
  • Also, please provide the model number from the serial number plate or sticker, and also please add that to the original post using edit. Please don't use [Add Comment] since if comments pile up, old comments get pushed offscreen. – K7AAY Jun 6 '19 at 15:47
  • Did you override the default of Mint 19, which uses a swap file forums.linuxmint.com/viewtopic.php?t=271029, when you created the swap partition? Or, are you using disk encryption, which creates an encrypted swap partition? Please advise with edit (op cit.) – K7AAY Jun 6 '19 at 17:09
0
*fsck failed with with exit status 4.

Exit status 4 from the fsck command means "filesystem contains errors that could not be corrected".

*Failed to start File System Check on /dev/disk/by-uuid/2ad686b0-e77b-47da-bb44-5934b5fa6541.

And on another filesystem, the filesystem check did not even start successfully.

The above messages suggest the system disk might be failing. You might want to boot the system from some external media, perhaps a Linux Live DVD/USB, and check the SMART health information of the disk, with e.g. smartctl -a /dev/sda or similar (adjust /dev/sda to refer to your actual system disk).

The rest of the messages don't seem critical to me. The signature & kernel tainting messages are simply caused by you using the proprietary NVidia GPU driver. Since the driver module isn't signed with the same key as the rest of the kernel modules, and the NVidia module signing key hasn't been explicitly whitelisted, the system warns you about it but lets it happen. If Secure Boot was enabled, the module would be prevented from loading.

"Tainting kernel" just means any kernel crash messages will be flagged as "non-open source modules in use, this will be hopeless to debug at kernel level unless the problem is reproduced without them."

| improve this answer | |
  • Thanks for your help. I ran smartctl as you suggested. All the "Pre-fail" and "Old-age" attributes were greater than their threshold values. The Self-test log structure analysis showed that the 5 short offline tests were error-free, while the 2 extended offline tests where "aborted by the host". The selective self-test log test were not carried out. From my brief online checks, these data suggest that HDD is OK, perhaps! – RoyS Jun 9 '19 at 7:37
  • While it's certainly reassuring, it is not a complete proof. A disk might still be failing in some way that is not covered by the SMART tests, but that is fairly rare. You might run a manual filesystem check on the problem filesystem (while the filesystem is unmounted) to see what kind of errors it might be reporting, perhaps that will provide more clues of what is going on. Or check the dmesg command output for I/O error messages; a bad SATA cable is another possible source of errors. – telcoM Jun 9 '19 at 7:51
  • I ran fsck using a live USB and it reported the /dev/sda2 to be clean. And I've had no more problems with Mint booting and running. This, I suppose, is slightly more reassuring :) The next steo is to enable the Nvidia driver which was automatically installed by Mint. I'm not expecting any problems there but one never knows! Thanks for your help, telcoM, it's much appreciated. – RoyS Jun 12 '19 at 1:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.