4

I run the Slack standalone application on an Ubuntu 16.04 machine which has two sound devices: the built-in sound, and a USB headset. I don't use a desktop environment, but I am running X and pulseaudio is running (as set up by default on Ubuntu).

I want all applications (Chrome, Slack, Skype, etc.) to use the USB headset for sound when it's plugged in. Until recently, this is the way it worked. I don't remember doing anything special to configure this. I just used the PulseAudio volume control application (pavucontrol) the first time (and only the first time) I used sound in the application: when the application appears in the “Playback” or “Recording” tab, switch it from “Built-in audio” to the USB headset, and the setting sticks for subsequent times.

Since a few days ago, this no longer works for Slack. Slack always the built-in audio even when the USB headset is plugged in. To use the headset for a Slack voice call, I need to wait until the call has started, then go to the “Playback” tab of PA Volume Control and switch the device (oddly, it also controls the recording direction).

I think the change happened when I upgraded from slack-desktop version 3.3.8 to 3.4.0. I use the package source https://packagecloud.io/slacktechnologies/slack/debian/ which is automatically set up by the slack-desktop package. The recent update to 4.0.0 didn't fix this.

How can I get Slack to always prefer the USB headset when it's present? I don't mind how it's done, but I want it to happen automatically. Losing audio for a few seconds at the beginning of a call while I fiddle with settings is not acceptable. And I want to keep using the standalone application for this, not a browser tab.

0

With Slack 4.0.0, during a call, I can access a settings screen where I can choose a different audio device, and this sticks to subsequent calls. At least if I don't restart Slack in between — I haven't tried that yet.

Notification pings still go to the wrong audio device.

0

For me, using pavucontrol to explicitly disable the other output devices worked. Specifically, marking them as "off" in the Configuration tab, NOT muting them in the Output tab

0
pavucontrol does not show (or allow control of) defaults for playback sink or recording source

but pasystray does show this in a GUI 

or

  1. find out names of default sink/source with pactl info
  2. use pactl list sinks and pactl list sourceto find all names
  3. pactl set-default-sink <name> replace '' with name from 2
  4. pactl set-default-source <name> replace '' with name from 2

or

  1. use pactl list sinks and copy 'Name' for correct device
  2. Go to home folder Pulseaudio configuration files and open file with name ending 'default sink' in a text editor (example: nano ~/.config/pulse/*default-sink)
  3. paste name from 1 and save
  4. repeat 1-3 above for source

default sink/source will be ignored if user changed sink output/source input in pavucontrol.
If that happens, move/rename Pulseaudio database file in ~/.config/pulse/ ending with 'card-database.tdb'
New database file will be created next time Pulseaudio (or system) restarted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.