0

Yesterday, my laptop with OpenSuse 15.1 died after a couple of years of use. I went out and bought a new HP Spectre X360 15 laptop (15-DF0033DX) that has 16GB of RAM, 1 256GB SSD NVMe drive, and don't even know what video it has since I am not super interested in that.

I went into the BIOS to make sure the boot order is:

1) CD/DVD Boot 2) USB Boot   3) HDD Boot

I also made sure that Legacy Boot is disabled and Secured Boot is disabled. There are 3 partitions on this drive: EFI Boot 260MB, C:\ with 475 GB of space, and a 27GB Restoration Drive. The C:\ drive had BitLocker on it for encryption, but I turned that off. This machine also has some sort of Intel Optane Memory and Storage management.

I have created a DVD for latest/greatest OpenSuse Leap 15.1 and I can boot to the installation. I get past half the installation where I can choose the KDE Desktop UI and then the next step is the Partitioning.

However, it is at this point that the OpenSuse says there is an error with the system and that it says: cannot delete mdContainer

For the life of me, I cannot even find these words anywhere on the internet, and I have spent literally the last 24 hours looking. The drive partitions it shows me are: 475 GB nvme0 and 27 GB nvme1.

When I go to create new partitions, it tells me that the drive is in use ... what could be using it and locking it like that?????? I've never had this issue before.

I tried to create a partition on the larger drive:

/efi/boot  1GB     FAT
/         20GB     BRTFS
/home     475GB    EXT4

I get the error that it tells me the device is being used, and I don't get to see what is using the drive ... just that it is being used?

Then I set my username/password, the system username/password, then I go with the default install for software since I will change it later ... and when I go to install ... the screen goes blank and then it starts the DOS-UI version of the installation ... and I go through the whole process all over again.

I tried to find an answer on the OpenSuse Forums, and I created a new account there, but I am unable to verify my registration because of problems on their side. So, I have come here as a last resort.

The next step might be to just delete the partitions in Windows 10 to just get rid of them and then hopefully that would be enough to do it. So, I am looking to find out what this error message means:

  cannot delete mdContainer

How can I fix this, if I can, and then install opensuse. I am also going to try installing Fedora on this machine if I can. Other sites I went to said they were able to install 5 different versions of Linux on the HP Spectre x360 laptop. So, maybe my system has a legitimate issue, and I need to exchange it?

1
  • How are you creating partitions? Do you use a live USB with GParted for example? Commented Jun 5, 2019 at 16:34

2 Answers 2

0

The new HP drive you want to format was initialized with Docker as that's a Docker error message. I'd ask HP Support how to erase/reformat the drive since that's their formatting borking up your nice clean install of OpenSUSE. Perhaps you got a not entirely new laptop?

1
  • Also, please delete your Comment to me under your original question as there's limited Comment space, which is why I suggest you put your findings in the original post with Edit.
    – K7AAY
    Commented Jun 5, 2019 at 18:10
0

The last two laptops I had came from the same company, where they provided an HDD, in one case it was a traditional spinning HDD, and the last one just had an SDD drive. In both these cases, install linux (OpenSuse) was a snap because you had an unpartitioned virgin HDD.

I seem to remember even farther in the past that regardless of my laptop/desktop, even if there was a Windows partition on it (NTFS or FAT), that my Linux installation would recognize the HDD and let me destroy those partitions and certainly letting me know that all that data would be destroyed.

Well, in this case ... there were those three partitions and OpenSuse wouldn't acknowledge the HDD. So, I looked into DBAN to Nuke/Wipe the drives, but that wouldn't boot. The BIOS had to be changed to setup the boot order, which I did. But I also told it to use legacy ENABLED and Secured Boot DISABLED. That was the first step, but DBAN still didn't.

So, then I used a LIVE CD for Fedora Workstation. I was able to boot to that Live CD (DVD) and then I installed a tool called GParted. This tool recognized the HDD, recognized the existing partitions created by Windows 10, and it let me Delete ALL those partitions. What was left was one fat 512GB SDD drive with ALL unallocated space.

Then I shut that down, and rebooted with my install of OpenSuse and that worked. NOW, Linux/OpenSuse did NOT come back with any error messages and suggested a new partition setup. I accepted the default that it had and let it go ...

Now I am able to install OpenSuse on my laptop. Case closed!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .