1

I'm attempting to connect a programmable vaping USB device to my Linux Mint laptop.

Each time I connect the device to laptop, I do not see the device appearing while monitoring lsusb via watch command.

Ive also monitored the kernel, and it seems that the kernel never recognizes the device. Only on one instance of inserting the USB, the kernel outputted:

LinuxMint kernel:  usb 2-1.1: new full-speed USB device number 8 using ehci-pci
LinuxMint kernel:  usb 2-1.1: new full-speed USB device number 9 using ehci-pci
LinuxMint kernel:  usb 2-1.1: device not accepting address 9, error -32

I suspected that this may be a hardware issue, so to rule it out, I tried from a Manjaro host. Each instance of testing, I could see the device being registered per lsusb.

The kernel reported:

Manjaro kernel: usb 2-2: device descriptor read/64, error -71
Manjaro kernel: usb 2-2: New USB device found, idVendor=268b, idProduct=0405, bcdDevice= 1.01
Manjaro kernel: usb 2-2: Product: Evolv DNA 200 USB
Manjaro kernel: usb 2-2: Manufacturer: Dimension Engineering

I presume that the below output is because I did not define a udev rule, nevertheless the kernel detects the device.

Manjaro kernel: hid-generic xxxx:xxxx:xxxx.xxxx: hiddev2,hidraw5: USB HID v1.10 Device [Dimension Engineering Evolv DNA 200 USB] on usb-0000:00:14.0-2/input0
Manjaro kernel: cdc_acm 2-2:1.1: ttyACM0: USB ACM device
mtp-probe[14653]: checking bus 2, device 14: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2"
mtp-probe[14671]: checking bus 2, device 14: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2"
ModemManager[597]: <info>  [device /sys/devices/pci0000:00/0000:00:14.0/usb2/2-2] creating modem with plugin 'Generic' and '1' ports
ModemManager[597]: <warn>  Couldn't create modem for device '/sys/devices/pci0000:00/0000:00:14.0/usb2/2-2': Failed to find primary AT port

I suspected that TLP power management on Mint might have been the cause per the USB autosuspend mode, but Ive turned this off.

Any suggestions on why the kernel does not detect device on Mint laptop ?

  • udev is likely the culprit. Is this a version based in buster? – Rui F Ribeiro Jun 5 at 6:16
  • I've got the latest Mint 19.1. I've tried the udev rule, reloaded and manually triggered, however device still does not get detected. – Seeker Jun 5 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.