I have a queer issue with my Arch-Linux System.

I am unable to get any Sound Output when playing audio, AFTER starting X Server.

The issue is not with Volume Controls or Sound Card Drivers because, if I start any kind of Audio playback BEFORE starting X Server, I have absolutely no issues. The Audio keeps playing even after X Server starts. But if I pause / stop the audio, on restarting playback, I get no audio output.

Even terminating X Server does not resolve this issue. Rebooting the system though, helps.

I tried with different DE's. Checked with GNOME, XFCE, LXDE, KDE. Same issue everytime. So It's not due to a particular environment, but rather an issue with X.

I am not sure what files I should be checking for this.

  • 1
    Maybe it's your desktop environment rather than the X server itself? How are you starting X? – donothingsuccessfully Oct 19 '12 at 9:20
  • No, I tried with various other Desktop Environments also. I am currently using XFCE. But the same issue persists in LXDE and GNOME3. I start X using: startxfce4 --with-ck-launch – darnir Oct 19 '12 at 9:32
  • The recommended way to start is now without --with-ck-launch. Just plain startxfce4 will do. – Salil Oct 20 '12 at 11:13
  • @Salil: Without using --with-ck-launch I cannot use the power options on my DE. Even after making the switch to systemd. In any case, I tried both ways, doesn't resolve my audio issue – darnir Oct 20 '12 at 12:17
  • funny thing is I started having the same problem a few days ago on my arch install. Maybe this is some regression or new bug? – Silverrocker Oct 21 '12 at 16:23

I do not think its related to Xorg anyhow. See if you have proper kernel modules loaded (lsmod). If it works after reboot that probably shouldn't be a problem though.


$ cat /etc/modules-load.d/snd_mixer_oss.conf 

Try running alsamixer or aumix as by default the audio is muted (strangely) or set very low (or not set by your X environment).


Does sound work if you start X with "startx" (not via gdm/kdm etc) and start a minimal windowmanager (like pekwm, not gnome or xfce)?

If it does, the problem is narrowed down somewhat.

Also, check if pulseaudio is started automatically or not.


Finally solved this problem thanks to help rendered on the #archlinux IRC Channel.

The issue was that for some odd reason, starting X would change the default Audio Output Device to my HDMI Card which was not being used to output audio.

On Arch Linux, I installed the package pavucontrol for PulseAudio and used it to reset the default device for audio playback to my on-board sound card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.