0

How could it be that I get easily an ip address with Windows 10 network manager and not with simple Linux QNAP NAS System?

Working example with Windows computer

And not working situation.

Not working for Linux

I tried to renew the ip address manually.

[admin@NAS ~]# dhclient -v eth3
Internet Systems Consortium DHCP Client 4.3.4
Copyright 2004-2016 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth3/24:5e:be:35:c3:23
Sending on   LPF/eth3/24:5e:be:35:c3:23
Sending on   Socket/fallback
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
$ ethtool eth3
Settings for eth3:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: on (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

I tried to set the network adapter to static with the IP address from Windows. Then I tried ping via ping -I eth3 8.8.8.8 which didn't worked, too.

I tried different ports, too - which results in different MAC addresses.

I dont know if the QNAP is to stupid to see the router or maybe the router ignores the QNAP. Or Linux dhclient is much different than Windows DHCP so that on windows it works and on linux not.

Maybe someone of you have few ideas :) Thanks in Advance!

  • If I remember correctly the NIC ports on a QNAP are labelled 1..4 but the corresponding internal names are eth0..3. Are you definitely using the correct port? – roaima Jun 4 at 23:16
  • Yes I have eth0..3 and I checked the cable within eth0 / port 1, eth1 / port 2, eth2 / port 3 and eth3 / port 4. Everywhere the same problem. :( – Patrick Jun 5 at 8:38
  • 1
    Please check ethtool eth3 | grep Link shows the link is up. You may also want to run ethtool eth3 and check that the physical characteristics match what you and your switch are expecting. – roaima Jun 5 at 8:40
  • First says Link detected: yes and second says few things. The question there is: How can I set the same characteristics as Windows? Then I could go through all points and set it like Windows does. :) I now tried to change the mac address via hal_app --se_sys_set_mac obj_index=3,value=EC:F4:AB:17:33:66 but even with the same MAC as the Windows Laptop I not get an IP Address. So yea maybe it's the characteristics. But within the QNAP Software I tried everything. 100MBits vs 1000MBits. And even the Jumbo Frame: 1500, 4074, 7418, 9000. So what could be the problem? Its the same cable. – Patrick Jun 5 at 8:51
  • 1
    You're describing the Nokia G-010G-P switch as a fibreoptic switch. Is it a fibre connection to the QNAP too, or a CAT5/6 wired connection? If it's a manged switch are there any MAC restrictions on the port you're using? There is something else connected to the switch that issues DHCP addresses isn't there...? – roaima Jun 5 at 10:02
0

Answer is easy after searching few hours... It's a VLAN!

It seems that the Windows devices are ignoring the VLAN or finding them by themself. (I checked via Powershell and it says there is an empty VLAN ID)

But at the end I called the fiber support and they told me the VLAN ID and after putting this VLAN ID to the linux systems (QNAP and OpenWRT Router) it works fine.

So very bad but now it's fine.

Thanks everybody for help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.