-2

I am using linux (Debian 8) on my VPS server. I use virtualmin to handle all domains. I created emails using 'create new user' in the 'edit users' section. I can send emails to others, but I am not able to receive emails.

What could be the problem?

closed as too broad by roaima, Rui F Ribeiro, dr01, Jeff Schaller Jun 7 at 19:39

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What have you done to tell external systems to deliver email for your domains to your VPS? – roaima Jun 4 at 8:01
  • can you please tell me what am i supposed to do? i have not done anything more than this. – Amit Jun 4 at 8:13
  • DNS MX records. Ensuring port 25 is open on your server. – roaima Jun 4 at 8:15
  • I use cloudflare. I have added an mx entry pointing to mail.mydomain.com. I have not done anything for port 25. how to open that port? – Amit Jun 4 at 8:19
  • 2
    Do you ever search for questions that others just maybe already have had? – Panki Jun 4 at 8:41
0

I solved the email issue by Configuring Postfix to not use ipv6. belos is way to do that.

add below line in your /etc/postfix/main.cf

inet_protocols = ipv4

and restart postfix using below command

systemctl restart postfix

i find above solution at below thread https://www.virtualmin.com/node/53447

Not the answer you're looking for? Browse other questions tagged or ask your own question.