-1

I have loads of data (fastq) to download from ENA database.

Example: ERS076383 ERS012262 ERS160574 ERS349280 etc

Link to download via browser: 

https://www.ebi.ac.uk/ena/data/warehouse/filereport?accession=ERS076383&result=read_run&fields=fastq_ftp&download=txt

Now i would link to replace accession= one by one to download corresponding txt then i would use wget to download each ftp link that are associated with fastq. but I am unable to download it by wget.

i tried: 

wget https://www.ebi.ac.uk/ena/data/warehouse/filereport?accession=ERS076383&result=read_run&fields=fastq_ftp&download=txt
[1] 61380
[2] 61381
[3] 61382

Redirecting output to 'wget-log'....

but it's not working.

0

You need to put the url in quotes, like this:

wget 'https://www.ebi.ac.uk/ena/data/warehouse/filereport?accession=ERS076383&result=read_run&fields=fastq_ftp&download=txt'

or escape the ampersands (\&).

  • Thanks its working ....i use -O option to change the filename as it gives me very strange file name. – Rupesh Jun 3 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.