Our cluster runs Linux, and I can successfully ssh login to it using my windows 10 PC. However, when I'm trying to use X11 forwarding I always get the error:

qt.qpa.screen: QXcbConnection: Could not connect to display localhost:0.0
Could not connect to any X display

I've tried everything: using Xterminal, PuTTY, Ubuntu (from the windows 10 store), MobaXterm - and nothing works. I've tried the export display command, and when I'm logging in I'm using -X (also tried -Y). I read online but couldn't find anything to work. Also, my colleague has a personal Macbook with the same user properties, and she managed to do X11 using XQuartz.

Any ideas what can I try?


When you connect to the Linux cluster with X11 forwarding, you allow X clients running on the cluster to contact your X server on your Windows 10 PC.

To make this work, you need to run an X server in the first place - and as Windows isn't Linux, no X server runs by default.

XQuartz is an X server for MacOS. Options for an X server for Windows are e.g. VcXsrv and Xming (not sure if it'll work on Windows 10) and the Cygwin X server. Possibly there are more.

And given the development of the Windows Subsystem for Linux (WSL), maybe there'll even be a native Microsoft X server at sometime in the future.

  • Yes I know that - I'm running Xerver on my windows machine (MobaXterm runs X server too). Xming is running in the background too but still, it doesn't work. – ValientProcess Jun 3 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.