0

If I run yum update, I get loads of errors:

    Error: Package: glib2-devel-2.54.2-2.el7.x86_64 (clearos-centos)
               Requires: glib2(x86-64) = 2.54.2-2.el7
               Removing: glib2-2.50.3-3.el7.x86_64 (@clearos)
                   glib2(x86-64) = 2.50.3-3.el7
               Updated By: glib2-2.56.1-2.el7.x86_64 (clearos)
                   glib2(x86-64) = 2.56.1-2.el7
               Available: glib2-2.54.2-2.el7.x86_64 (clearos-centos)
                   glib2(x86-64) = 2.54.2-2.el7
    Error: Package: 1:openssl-devel-1.0.2k-12.el7.x86_64 (clearos-centos)
               Requires: openssl-libs(x86-64) = 1:1.0.2k-12.el7
               Removing: 1:openssl-libs-1.0.2k-8.el7.x86_64 (@clearos)
                   openssl-libs(x86-64) = 1:1.0.2k-8.el7
               Updated By: 1:openssl-libs-1.0.2k-16.el7_6.1.x86_64 (clearos)
                   openssl-libs(x86-64) = 1:1.0.2k-16.el7_6.1
               Available: 1:openssl-libs-1.0.2k-12.el7.x86_64 (clearos-centos)
                   openssl-libs(x86-64) = 1:1.0.2k-12.el7
    Error: Package: libselinux-devel-2.5-12.el7.x86_64 (clearos-centos)
               Requires: libselinux(x86-64) = 2.5-12.el7
               Removing: libselinux-2.5-11.el7.x86_64 (@clearos)
                   libselinux(x86-64) = 2.5-11.el7
               Updated By: libselinux-2.5-14.1.el7.x86_64 (clearos)
                   libselinux(x86-64) = 2.5-14.1.el7
               Available: libselinux-2.5-12.el7.x86_64 (clearos-centos)
                   libselinux(x86-64) = 2.5-12.el7
    Error: Package: libsepol-devel-2.5-8.1.el7.x86_64 (clearos-centos)
               Requires: libsepol(x86-64) = 2.5-8.1.el7
               Removing: libsepol-2.5-6.el7.x86_64 (@anaconda/7.3.0.192627)
                   libsepol(x86-64) = 2.5-6.el7
               Updated By: libsepol-2.5-10.el7.x86_64 (clearos)
                   libsepol(x86-64) = 2.5-10.el7
               Available: libsepol-2.5-8.1.el7.x86_64 (clearos-centos)
                   libsepol(x86-64) = 2.5-8.1.el7
    Error: Package: libgudev1-219-57.el7_5.3.x86_64 (clearos-centos-updates)
               Requires: systemd-libs = 219-57.el7_5.3
               Removing: systemd-libs-219-42.el7_4.10.x86_64 (@clearos-centos-updates)
                   systemd-libs = 219-42.el7_4.10
               Updated By: systemd-libs-219-62.el7_6.6.x86_64 (clearos)
                   systemd-libs = 219-62.el7_6.6
               Available: systemd-libs-219-57.el7.i686 (clearos-centos)
                   systemd-libs = 219-57.el7
               Available: systemd-libs-219-57.el7_5.1.x86_64 (clearos-centos-updates)
                   systemd-libs = 219-57.el7_5.1
               Available: systemd-libs-219-57.el7_5.3.x86_64 (clearos-centos-updates)
                   systemd-libs = 219-57.el7_5.3
    Error: Package: audit-libs-python-2.8.1-3.el7_5.1.x86_64 (clearos-centos-updates)
               Requires: audit-libs(x86-64) = 2.8.1-3.el7_5.1
               Removing: audit-libs-2.7.6-3.el7.x86_64 (@clearos)
                   audit-libs(x86-64) = 2.7.6-3.el7
               Updated By: audit-libs-2.8.4-4.el7.x86_64 (clearos)
                   audit-libs(x86-64) = 2.8.4-4.el7
               Available: audit-libs-2.8.1-3.el7.x86_64 (clearos-centos)
                   audit-libs(x86-64) = 2.8.1-3.el7
               Available: audit-libs-2.8.1-3.el7_5.1.x86_64 (clearos-centos-updates)
                   audit-libs(x86-64) = 2.8.1-3.el7_5.1
    Error: Package: policycoreutils-python-2.5-22.el7.x86_64 (clearos-centos)
               Requires: policycoreutils = 2.5-22.el7
               Removing: policycoreutils-2.5-17.1.el7.x86_64 (@clearos)
                   policycoreutils = 2.5-17.1.el7
               Updated By: policycoreutils-2.5-29.el7_6.1.x86_64 (clearos)
                   policycoreutils = 2.5-29.el7_6.1
               Available: policycoreutils-2.5-22.el7.x86_64 (clearos-centos)
                   policycoreutils = 2.5-22.el7
    Error: Package: python-devel-2.7.5-69.el7_5.x86_64 (clearos-centos-updates)
               Requires: python(x86-64) = 2.7.5-69.el7_5
               Removing: python-2.7.5-58.el7.x86_64 (@clearos)
                   python(x86-64) = 2.7.5-58.el7
               Updated By: python-2.7.5-77.el7_6.x86_64 (clearos)
                   python(x86-64) = 2.7.5-77.el7_6
               Available: python-2.7.5-68.el7.x86_64 (clearos-centos)
                   python(x86-64) = 2.7.5-68.el7
               Available: python-2.7.5-69.el7_5.x86_64 (clearos-centos-updates)
                   python(x86-64) = 2.7.5-69.el7_5
    Error: Package: systemd-python-219-57.el7_5.3.x86_64 (clearos-centos-updates)
               Requires: systemd-libs = 219-57.el7_5.3
               Removing: systemd-libs-219-42.el7_4.10.x86_64 (@clearos-centos-updates)
                   systemd-libs = 219-42.el7_4.10
               Updated By: systemd-libs-219-62.el7_6.6.x86_64 (clearos)
                   systemd-libs = 219-62.el7_6.6
               Available: systemd-libs-219-57.el7.i686 (clearos-centos)
                   systemd-libs = 219-57.el7
               Available: systemd-libs-219-57.el7_5.1.x86_64 (clearos-centos-updates)
                   systemd-libs = 219-57.el7_5.1
               Available: systemd-libs-219-57.el7_5.3.x86_64 (clearos-centos-updates)
                   systemd-libs = 219-57.el7_5.3
    Error: Package: samba-client-libs-4.8.3-4.4.v7.x86_64 (clearos-updates)
               Requires: libldb.so.1(LDB_1.3.0)(64bit)
    Error: Package: gcc-4.8.5-28.el7_5.1.x86_64 (clearos-centos-updates)
               Requires: libgomp = 4.8.5-28.el7_5.1
               Removing: libgomp-4.8.5-16.el7_4.2.x86_64 (@clearos-centos-updates)
                   libgomp = 4.8.2-16.el7_4
                   libgomp = 4.8.5-16.el7_4.2
               Updated By: libgomp-4.8.5-36.el7_6.2.x86_64 (clearos)
                   libgomp = 4.8.5-36.el7_6.2
                   libgomp = 4.8.2-16.el7_6
               Available: libgomp-4.8.5-28.el7.i686 (clearos-centos)
                   libgomp = 4.8.5-28.el7
                   libgomp = 4.8.2-16.el7
               Available: libgomp-4.8.5-28.el7_5.1.x86_64 (clearos-centos-updates)
                   libgomp = 4.8.5-28.el7_5.1
                   libgomp = 4.8.2-16.el7_5
    Error: Package: glibc-2.17-222.el7.i686 (clearos-centos)
               Requires: glibc-common = 2.17-222.el7
               Removing: glibc-common-2.17-196.el7_4.2.x86_64 (@clearos-centos-updates)
                   glibc-common = 2.17-196.el7_4.2
               Updated By: glibc-common-2.17-260.el7_6.4.x86_64 (clearos)
                   glibc-common = 2.17-260.el7_6.4
               Available: glibc-common-2.17-222.el7.x86_64 (clearos-centos)
                   glibc-common = 2.17-222.el7
    Error: Package: libkadm5-1.15.1-19.el7.x86_64 (clearos-centos-updates)
               Requires: krb5-libs(x86-64) = 1.15.1-19.el7
               Removing: krb5-libs-1.15.1-8.el7.x86_64 (@clearos)
                   krb5-libs(x86-64) = 1.15.1-8.el7
               Updated By: krb5-libs-1.15.1-37.el7_6.x86_64 (clearos)
                   krb5-libs(x86-64) = 1.15.1-37.el7_6
               Available: krb5-libs-1.15.1-18.el7.x86_64 (clearos-centos)
                   krb5-libs(x86-64) = 1.15.1-18.el7
               Available: krb5-libs-1.15.1-19.el7.x86_64 (clearos-centos-updates)
                   krb5-libs(x86-64) = 1.15.1-19.el7
    Error: Package: systemd-python-219-57.el7_5.3.x86_64 (clearos-centos-updates)
               Requires: systemd = 219-57.el7_5.3
               Removing: systemd-219-42.el7_4.10.x86_64 (@clearos-centos-updates)
                   systemd = 219-42.el7_4.10
               Updated By: systemd-219-62.el7_6.6.x86_64 (clearos)
                   systemd = 219-62.el7_6.6
               Available: systemd-219-57.el7.x86_64 (clearos-centos)
                   systemd = 219-57.el7
               Available: systemd-219-57.el7_5.1.x86_64 (clearos-centos-updates)
                   systemd = 219-57.el7_5.1
               Available: systemd-219-57.el7_5.3.x86_64 (clearos-centos-updates)
                   systemd = 219-57.el7_5.3
    Error: Package: krb5-devel-1.15.1-19.el7.x86_64 (clearos-centos-updates)
               Requires: krb5-libs(x86-64) = 1.15.1-19.el7
               Removing: krb5-libs-1.15.1-8.el7.x86_64 (@clearos)
                   krb5-libs(x86-64) = 1.15.1-8.el7
               Updated By: krb5-libs-1.15.1-37.el7_6.x86_64 (clearos)
                   krb5-libs(x86-64) = 1.15.1-37.el7_6
               Available: krb5-libs-1.15.1-18.el7.x86_64 (clearos-centos)
                   krb5-libs(x86-64) = 1.15.1-18.el7
               Available: krb5-libs-1.15.1-19.el7.x86_64 (clearos-centos-updates)
                   krb5-libs(x86-64) = 1.15.1-19.el7
    Error: Package: samba-winbind-4.8.3-4.4.v7.x86_64 (clearos-updates)
               Requires: libtevent.so.0(TEVENT_0.9.36)(64bit)
    Error: Package: libcom_err-devel-1.42.9-12.el7_5.x86_64 (clearos-centos-updates)
               Requires: libcom_err(x86-64) = 1.42.9-12.el7_5
               Removing: libcom_err-1.42.9-10.el7.x86_64 (@clearos)
                   libcom_err(x86-64) = 1.42.9-10.el7
               Updated By: libcom_err-1.42.9-13.el7.x86_64 (clearos)
                   libcom_err(x86-64) = 1.42.9-13.el7
               Available: libcom_err-1.42.9-11.el7.x86_64 (clearos-centos)
                   libcom_err(x86-64) = 1.42.9-11.el7
               Available: libcom_err-1.42.9-12.el7_5.x86_64 (clearos-centos-updates)
                   libcom_err(x86-64) = 1.42.9-12.el7_5
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

closed as unclear what you're asking by Rui F Ribeiro, GAD3R, Sparhawk, Kiwy, roaima Jun 9 at 21:58

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Which repository/repositories are you using? Is it an official ClearOS mirror site, and is that mirror site OK? You might want to try another mirror site, in case your normal mirror site has had some problems mirroring the content from the ClearOS main repository. – telcoM Jun 9 at 11:35
1

Looks like a problem with your EPEL repos. I would suggest you removing all repos and adding them anew, eg.

rm /etc/yum.repos.d/epel*.repo
yum clean all
yum install epel-release
yum update
  • Package epel-release-7-11.noarch is obsoleted by clearos-release-7-5.5.v7.x86_64 which is already installed – Nikki Locke Jun 3 at 16:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.