2

I tried to install using the documentation found here (https://wiki.archlinux.org/index.php/Bumblebee), but when running:

optirun glxgears -info

I get this output:

[  309.531594] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nouveau" (module does not exist, 0)
[  309.531645] [ERROR]Aborting because fallback start is disabled.

I have two video cards: one integrated from Intel and a dedicated GeForce GTX 960M.

The output of inxi -G:

    Graphics:
      Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
      Device-2: NVIDIA GM107M [GeForce GTX 960M] driver: nouveau v: kernel 
      Display: wayland server: X.Org 1.20.4 driver: nouveau 
      resolution: 1920x1080~60Hz 
      OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
      v: 4.5 Mesa 19.0.4

The output of lspci -v about video cards:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) (prog-if 00 [VGA controller])
    DeviceName: Intel Skylake HD Graphics ULT GT2
    Subsystem: Hewlett-Packard Company HD Graphics 530
    Flags: bus master, fast devsel, latency 0, IRQ 132
    Memory at a2000000 (64-bit, non-prefetchable) [size=16M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 5000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
        DeviceName: NVIDIA N16P-GX
        Flags: bus master, fast devsel, latency 0, IRQ 134
        Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        Memory at a0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Expansion ROM at a4000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nouveau
        Kernel modules: nouveau
  • I've done a bit of work with this. To run OpenGL apps with Bumblebee on an Optimus Laptop I had to install a pre-compiled nvidia driver for my kernel that was Bumblebee aware. I think I got everything I needed from ElRepo for RHEL/CENTOS7. Its been a year, no complaints from the end user yet. – pacmanwa May 31 '19 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.