Debian Jessie installed on external USB SSD drive. Xfce desktop environment.

kernel release 3.16.0-8-686-pae, SMP Debian 3.16.64-2, Hardware architecture i686 (32-bit system)

I can't get sound working. Alsa sound architecture. I tried various settings, but nothing worked. The Red X mark is shown on speaker in the upper right hand corner.

2 Answers 2


I solved this issue myself.

Settings > Settings Editor > select 'xfce4-mixer' (left pane) > select 'sound-card' > click 'Reset' button. Log out, then Log in.

To fix a muted sound icon (Red X mark): right click on speaker icon > 'Run Audio Mixer'. This open "Audio Mixer - HDA Intel PCH (Alsa mixer)". From there select the correct speaker icon (internal speaker, mic, headset, etc) and adjust the volume levels of individual components.


Make sure your Soundcard/Modem/etc was actually detected and shows as valid. Generally speaking if it says UNCLAIMED or DISABLED then it probably wasnt detected/configured right

Try running

sudo lshw -C multimedia

To make sure that isnt the case

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .