0

I have two CentOS hosts and want to install the kernel module crc32_intel_glue.  I don't find it in the official repo, so I tried to build it from source, and failed.

I downloaded crc32c-intel_glue.c and Makefile from this web page:

https://raw.githubusercontent.com/torvalds/linux/master/arch/x86/crypto/

I tried

yum install kernel-headers
make crc32c-intel_glue

but it outputs a ton of errors:

cc     crc32c-intel_glue.c   -o crc32c-intel_glue
crc32c-intel_glue.c:27:24: error: linux/init.h: No such file or directory
crc32c-intel_glue.c:28:26: error: linux/module.h: No such file or directory
crc32c-intel_glue.c:31:34: error: crypto/internal/hash.h: No such file or directory
crc32c-intel_glue.c:32:34: error: crypto/internal/simd.h: No such file or directory
crc32c-intel_glue.c:34:29: error: asm/cpufeatures.h: No such file or directory
crc32c-intel_glue.c:35:31: error: asm/cpu_device_id.h: No such file or directory
crc32c-intel_glue.c:36:22: error: asm/simd.h: No such file or directory

etc...


CentOS 6.10

zgrep CONFIG_CRYPTO_CRC32C_INTEL /boot/config-*

returns

CONFIG_CRYPTO_CRC32C_INTEL=m

I looked for crc32c-intel.ko and I found it:

/lib/modules/2.6.32-754.14.2.el6.x86_64/kernel/arch/x86/crypto/crc32c-intel.ko

I want to compile the module on Centos 5.11, to understand how it works.

  • 2
    Which CentOS version? Also, do you have the CentOS kernel config available? (Check /boot). If so, check it for CONFIG_CRYPTO_CRC32C_INTEL. – derobert May 29 at 18:35
  • I'm pretty sure that crc32c-intel.ko you found is the module you're looking for. Note how it matches the driver name and aliases in that source file. Is it not available on 5.11? You often can't grab modules from a newer kernel without upgrading the kernel entirely (or work backporting the module). – derobert May 29 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.