0

I've got a CentOS7 server joined to a Windows Active Directory Server. I'm trying to connect to CentOS using my Active Directory credentials but it seems that it checks the local account as first step and LDAP as second. That's because I'm receiving a message that order me to change the local account password. Is there a way to change the authentication order in order to check LDAP as first step and local account as second?

This is my nsswitch.conf

....
passwd:     ldap files sss
shadow:     ldap files sss
group:      ldap files sss
....

  • How are you connecting to your CentOS system? SSH? – jsbillings Jun 2 at 16:28
  • 1
    If you have solved your problem, consider posting an answer. – muru Jun 4 at 8:13
  • Welcome to Unix Stackexchange! You should really take the tour. I am sorry to bother you but this is not a forum, there are no threads to close. You'd answer to your own question and, eventually, mark it as "accepted". – andcoz Jun 4 at 9:20
0

Maybe, I found the solution. I'm using SSS which is using OpenLDAP not LDAP. So, is it possible to switch "sss" parameter before "files" in order to run sssd on the right way.

....
passwd:     sss files
shadow:     sss files
group:      sss files
....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.