0

I'm having some issues with a yum update after updating a local repository. I am getting several errors which all include reference to glibc-2.17-196.el7_4.2.i686:

Error: Package: rsyslog-8.24.0-12.el7.x86_64 (@anaconda/7.0)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
           Removing: glibc-2.17-196.el7.x86_64 (@anaconda/7.0)
               libc.so.6(GLIBC_2.17)(64bit)
           Updated By: glibc-2.17-196.el7_4.2.i686 (Rocks-7.0)
               Not found

Does this mean that yum can't find glibc? or can it not find rsyslog? glibc.i686 is not currently installed but glibc.x86_64 is.

The Rocks-7.0 is local and I have checked that the relevant RPMS are available on the baseurl. yum also thinks that they are part of the repository as I can get information about them using

yum list
  • 1
    Issue is your repos having newest glibc version which don't have libc.so.6. Also architecture of rpm are different. You can remove glibc from Rocks-7.0 and create repo again. It should work post that – asktyagi May 29 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.