8

Starting this morning I'm getting errors checking for updates to packages with yum on Centos 7.6. When I run:

$ sudo yum clean all && sudo yum check-update
Loaded plugins: fastestmirror, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Cleaning repos: base epel extras google-cloud-compute google-cloud-sdk updates
Cleaning up list of fastest mirrors
Other repos take up 1.5 M of disk space (use --verbose for details)
Loaded plugins: fastestmirror, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
Determining fastest mirrors
epel/x86_64/metalink                                                         |  15 kB  00:00:00
 * base: mirror.cogentco.com
 * epel: mirror.steadfastnet.com
 * extras: mirror.cogentco.com
 * updates: mirror.cogentco.com
base                                                                         | 3.6 kB  00:00:00
epel                                                                         | 4.9 kB  00:00:00
extras                                                                       | 3.4 kB  00:00:00
google-cloud-compute/signature                                               |  454 B  00:00:00
google-cloud-compute/signature                                               | 1.8 kB  00:00:00 !!!
google-cloud-sdk/signature                                                   |  454 B  00:00:00
google-cloud-sdk/signature                                                   | 1.4 kB  00:00:00 !!!
updates                                                                      | 3.4 kB  00:00:00
(1/9): base/7/x86_64/group_gz                                                | 166 kB  00:00:00
(2/9): extras/7/x86_64/primary_db                                            | 200 kB  00:00:00
(3/9): epel/x86_64/group_gz                                                  |  88 kB  00:00:00
(4/9): base/7/x86_64/primary_db                                              | 6.0 MB  00:00:00
(5/9): epel/x86_64/primary_db                                                | 6.7 MB  00:00:00
(6/9): updates/7/x86_64/primary_db                                           | 5.0 MB  00:00:00
(7/9): google-cloud-compute/updateinfo                                       | 1.1 kB  00:00:00
(8/9): google-cloud-compute/primary                                          | 3.6 kB  00:00:00
(9/9): google-cloud-sdk/primary                                              | 100 kB  00:00:00
google-cloud-compute                                                                          10/10
google-cloud-sdk                                                                            705/705
Updateinfo file is not valid XML: <open file '/var/cache/yum/x86_64/7/epel/92f2e15cad66d79ea1ad327e2af7af89d98e4d153d7a3e27ff41946f476af5b4-updateinfo.xml.zck', mode 'rt' at 0x7f4a26819ed0>

So it looks like it doesn't like the EPEL updateinfo but... what can I do about that? How can I fix this?

I found this, but I don't understand how it might apply to me?

Edit: Apparently updates work, only check-update fails. Which is a nuisance because cron runs check-update hourly and my inbox explodes. But I can still run updates.

Edit 2: It appears maybe something is going wrong with EPEL at the moment and I have to adjust my cron jobs for now.

  • 1
    you can disable the epel repo until they get their act together? – Grump May 29 at 16:03
  • Can you check if 'baseurl:' line is uncommented and comment 'metalink:' line works for you in your epel repo? – asktyagi May 29 at 16:44
  • If your problem is not alleviated by using yum clean all or pointing to another mirror, then the error is most likely with EPEL itself, and you would need to wait until they get it fixed. It looks like you may be able to comment out the metalink line in the EPEL repo config and uncomment the baseurl to get it working until it gets fixed upstream. If none of that works, will need to disable the EPEL repo until they fix it properly. – GracefulRestart May 29 at 17:08
  • @asktyagi @GracefulRestart I commented metalink and uncommented baseurl and it's still throwing the same error. I can update most packages by disabling epel like @Grump suggested... – Chris May 29 at 17:30
  • have you commented metalink and uncommented baseurl, post that clean the repo and tried to update? try sequentially not inline. – asktyagi May 29 at 17:33
7

This is due to a bug in the bodhi-4.0.0 release which is apparently in the framework of the epel repo infrastructure. The bug caused incompatible update files to be generated and pushed to the production repos. A new update has been released and the repos should be repaired soon.

4

it seems to be new version of bodhi (bodhi-4.0.0) deployed.it should fix this issue. Please refer this https://pagure.io/releng/issue/8392 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.