0

I have 2 monitors, one connected with a hdmi cable to my pc and one connected with a vga cable and a dvi-i to vga adapter, plugged in the dvi-i port of my gpu.
Under Windows 7, it works perfectly but under debian 9 (lxde), i dont get an output. xrandr gives me only my hdmi connection.

In Menu > Settings > Monitor Settings is only the hdmi monitor displayed.
My graphic card is amd radeon r9 270, drivers are installed.
I have tested this setup with other desktop environments either but with no success.
The second screen works during boot just when lxde starts, it looses the signal.

To buy an other hdmi cable is no solution because my gpu has only one hdmi port (and 1 dvi-i, 1 dvi-d and a display port). Also a dvi to hdmi cable didnt work (pc - dvi - hdmi - monitor)

My target is to extend my desktop.

EDIT kemotep:

I have downloaded my gpu driver here
https://www.amd.com/en/support/previous-drivers/graphics/amd-radeon-r9-series/amd-radeon-r9-200-series/amd-radeon-r9-270
and executed the file after download.

My package manager (synaptic) tells me that the drivers are installed (I have searched for radeon)

I haven't configured my display because debian doesn't discover it.

"and yes, I have asked Google..." yes, there are thousand guides out there how to setup dual monitors. Most of them did not faced my problem. Under linux, my 2nd monitor is not displayed at all.

K7AAY: It is not the hardware's fault because my monitors are working fine with win7. Its anything with linux...

  • Welcome to the the Unix and Linux stack exchange! Please review the Help Center to get information on how to best post to the site. Take the Tour if you are not familiar with how this site works. To get to your question, could you outline the exact steps you took to install your drivers, and configure your display? Have you looked up how to setup dual monitor under LXDE specifically? If so link the guide. Please edit your post to include these details. Thank you! – kemotep May 28 '19 at 17:03
  • updated @kemotep . edit - i was at stackoverflow before so im not completely new – Schn33W0lf May 28 '19 at 18:46
  • I know this may be frustrating but you need to not install your graphics drivers that way when you use Debian. Please remove all of your graphics drivers and settings, in some cases a reinstall of your operating system will be cleaner and faster, and install your graphics drivers following this information. After you have done that please edit your post to include the output of lscpi -nn | grep vga and xrandr. Confirm that your monitor is connected and powered on. Settings > Display Settings should detect the 2nd monitor as soon as you plug it in. – kemotep May 28 '19 at 18:59
  • it returns command not found. but this doesnt matter after ive installed the drivers anr rebooted i had a 2nd monitor by default. while booting, there where any error messages that amd doesnt find anything but its working. never change a running system. thx :P – Schn33W0lf May 28 '19 at 20:24
  • sorry that should have been lspci not lscpi that is my mistake. The best way to manage your Debian system and have the most "stable" experience is to only install and update packages through the Debian package manager apt and only use the official repositories for your given Debian release. I am glad to hear everything is working now. – kemotep May 28 '19 at 20:36
-1

kemotep's link, https://wiki.debian.org/AtiHowTo, solved it if I'm remembering correctly.

| improve this answer | |
  • If you could explain the steps you followed, or didn't follow, or adjusted, from the link, that'd be helpful for future readers; thank you! – Jeff Schaller Mar 16 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.