-1

I'm stuck with my netbook (Dell Latitude 3380). Used it for a year: worked fine. I bought and put new SSD, installed Kubuntu 18.04 on it. For a couple hours it worked very well. Then it froze when I was copying files from external HDD and doing some stuff. Then it worked really slowly so I thought to give 19.04 a try. Now, I guess, is a big mistake: I manually changed partition table. Previously there was one ext4 partition mounted as /, second one as /home and swap. I deleted the first one, created 200MB EFI at the begining, rest formatted again to ext4, /. I left /home and swap without formatting.

System installed with no errors or warnings, but after rebooting there is only grub rescue. I can use it to boot linux from Live USB (this is how I write this) - so the module files are there and can be read. (I can, of course, boot directly from USB by BIOS). GRUB sees partition on this disk. /dev/sda1 (EFI partition) is set as BOOT but system itself and GRUB files are on /dev/sda7. I guess this is a problem.

But any attempt to use gparted, fdisk, wipefs or fsck on my /dev/sda from either Ubuntu Live or System Rescue CD Live ends with weird error. Every two minutes I get messages like:

INFO: task fsck.ext2:6081 blocked for more than 120 seconds.
Not tainted 4.19.34-1-lts #1

ctrl+c doesn't help. I've to do a hard reset. Kubuntu installer gives me error messages like "/dev/sda1/" cannot be accessed so I can't proceed further than time zone setting. My BIOS has an option to wipe internal disk. I run it, but it ends with error and no details. I did

dd if=/dev/zero of=/dev/sda

and left the computer overnight. Worked without errors, wrote ca 512GB of zeros but nothing really changed ;P Partitions are still there, as I can see them from grub rescue. I was able to run fdisk-l once and saw partition table. Then I tried fsck /dev/sda and it again produced "not tainted" situation.

What's going on in here? Is this a faulty SSD? Seems not, because on my first installation I was able to use it quite normally. SMART also shows no errors. I don't care, obviously, about any data on the disk. I just want to do whatever to make a clean install of a new Kubuntu (or Mint or whatever).

This is blkid output:

/dev/sda1: UUID="D66B-BF6C" TYPE="vfat" PARTUUID="b9d3b90b-01"
/dev/sda5: UUID="eec4f953-b9ba-4579-95f4-8f9a8d6821a3" TYPE="ext4" PARTUUID="b9d3b90b-05"
/dev/sda7: UUID="8b9d60f7-fa03-459a-9d34-784d4259338a" TYPE="ext4" PARTUUID="b9d3b90b-07"

Some additional info: My netbook has been working fine for a year on Kubuntu 16.04, except that once in a long while it hanged up with some I/O error, message contained also a sector number of HDD. (if you think it's relevant, I can provide more detailed desc)

My new SSD is Goodram CX400 512GB.

Whenever I boot USB with Kubuntu 18.04, 19.04, Mint 19.1 or Fedora 30 KDE I see such messages (didn't see them while on Kubuntu 16.04):

May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee2000000040110a
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: TSC 0 ADDR fef1ce80 MISC 43880014086 
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1559025486 SOCKET 0 APIC 0 microcode 9a
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: Machine check events logged
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 7: ee2000000040110a
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: TSC 0 ADDR fef1cec0 MISC 47880014086 
May 28 06:38:22 kubuntu kernel: mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1559025486 SOCKET 0 APIC 0 microcode 9a

I found people having similar issues on Dell laptops and claiming that these are false positives (example1, example2).

Memtest after few passes produces no errors at all.

  • Some issue with your hardware itself check BIOS. – asktyagi May 28 at 9:14
  • What do you precisely mean? There's a diagnostic tool in my BIOS but I run it and it claims that everything is ok: "all tests passed". As I wrote, memtest and SMART didn't report anything. Any suggestions what else if my hardware and how I should test then? – Piotr L. May 28 at 9:28
  • Possible reasons for the timeout are explained here, the issue with fsck on a clean boot makes and inaccessibilty to gparted it sound hardware related. What is the old SSD model? And if you reinstall it, does the machine function? – bu5hman May 28 at 10:00
  • @bu5hman : the old disk was actually a HDD, Toshiba MQ01ACF050. I reinstalled it and everything works just fine. So it's all just a broken new SSD? – Piotr L. May 29 at 8:34
  • I misunderstood your original post (thought the old was SSD) but I was fishing to see if the issue was SATA/nvme related. My laptop will take an M2 SATA but not nvme was an issue I was looking for with you, but the fact that you installed and ran for a while (drivers must have been there) before failing and then have read/formatting issues suggests hardware to me. If the old disk boots and runs fine then that points to the SSD itself rather than a connector or motherboard issue. – bu5hman May 29 at 9:20
0

Since all write operations fail and the data is preserved it very much sounds as if the drive has set itself as read only, probably as the result of an error condition (over-heating, power surge etc).

Mail the manufacturers tech support and explain the problem. They may help with a fix/reset or possibly replace the drive.

support@goodram.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.