1

I have tried:

sudo apt-get remove r-base

sudo apt-get remove r-base-core

delete everything in .libPaths()

The thing is, I'm using a Docker container which came with R installed in it. When I run those commands, the terminal prompts:

Package 'r-base-core' is not installed, so not removed

The reason why I'm trying to uninstall R from a container built for using R is that what I really need is to use Oracle R Enterprise and it only works for R version 3.3.0. The version that came already installed in the container is 3.6.0

With this set, I can think of 2 possible solutions to my problem:

  1. Remove everything in the paths that .libPaths() show and hope that works. Would be awesome if someone could confirm if that would work before I try it and mess everything up.
  2. Find a way to downgrade to 3.3.0 version from 3.6.0 version so I don't have to uninstall and re-install R again.

migrated from askubuntu.com May 27 at 10:27

This question came from our site for Ubuntu users and developers.

2

If you take a look on a Dockerfile which is being used for that particular image, there's really no r-base or r-base-core packages. It looks like r comes as a part of rstudio-server package.

You might want to use older version of rstudio-server package. Normally it's not a good idea to mess with files from deb-packages manually.

PS. Instead of applying change to already existing container, it might be much better to build your own image based on modified version of Dockerfile which is used for rstudio.

  • In the end that is the best option, you're right. I wanted to cut corners by changing directly within the container but the use of Docker is recommended for what you just said, building containers from images that I can tune myself. Thanks for the answer. – AliAs May 27 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.