0

We have 4 backup disks that we rotate in one removable caddy slot. The fstab script intermittently works....it appears the fstab script is not getting to later lines.

Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-148-generic x86_64)

Example - this will NOT mount the 3rd disk (1C66E504730C5C29)

/dev/mapper/SERVER--vg-root     /       ext4    errors=remount-ro       0       1
UUID=a29ab6b9-65c2-4431-858a-bfd9e4de86ee       /boot   ext2    defaults        0       2
/dev/mapper/SERVER--vg-swap_1    none   swap    sw      0       0

UUID=55AA6B0B696C3208   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
UUID=1447ECF46C1947D4   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
UUID=1C66E504730C5C29   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
UUID=09749B074D92BDE8   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0

But this will

/dev/mapper/SERVER--vg-root     /       ext4    errors=remount-ro       0       1
UUID=a29ab6b9-65c2-4431-858a-bfd9e4de86ee       /boot   ext2    defaults        0       2
/dev/mapper/SERVER--vg-swap_1    none   swap    sw      0       0

# UUID=55AA6B0B696C3208   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
# UUID=1447ECF46C1947D4   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
UUID=1C66E504730C5C29   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0
# UUID=09749B074D92BDE8   /mnt/backupdrives       ntfs-3g defaults,nofail 0       0

We are left having to "mount -a" :(

(have tried replacing "defaults" with "auto" :( Is their a limit to the number of "nofail's" or another option

Any direction greatly appreciated

1 Answer 1

0

With nofail, this mount will be only wanted, not required, by local-fs.target or remote-fs.target. This means that the boot will continue even if this mount point is not mounted successfully. And I think ntfs-3g doesn't support nofail please refer https://www.tuxera.com/community/open-source-ntfs-3g/

2
  • Cheers - ntfs-3g came about through desperate measures :( use to be ntfs - but that behaves the same :( Have changed back to ntfs - will try including a delay May 27, 2019 at 10:15
  • The part about ntfs-3g not supporting nofail is flat-out wrong. That option is not filesystem dependent; read the manpage for fstab: "Basic filesystem-independent options are:(…) nofail do not report errors for this device if it does not exist."
    – Wyatt Ward
    Aug 10, 2020 at 17:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .