-1

update description Whenever I try to update my Kali Linux or whenever I install new apps, it fails. I get the following logs. How can I fix this?

  • 2
    Debian servers do not have kali repositories. I would advise consulting the official kali site instead of following random pages. – Rui F Ribeiro May 27 at 6:26
  • 2
    Hi and welcome! Thanks for contributing! But please, don't post images of text (read this for reasons why). – Kusalananda May 27 at 7:00
  • Hello Kusalanada, Actually I posted a image to make the answerers confirm that, I am running the commands as a root. – Space May 27 at 7:08
4

For Kali rolling, you need to ensure that the following line is present in `/etc/apt/sources.list:

deb http://http.kali.org/kali kali-rolling main non-free contrib

You’ll also have to delete the debian-security line, it’s irrelevant for Kali.

After you’ve made these changes, run

apt update

to update your local indexes.

  • I tried executing: echo "deb http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list But it solved only update problem. The apps are not being properly installed – Space May 27 at 6:30
  • What does apt install xfburn say now? – Stephen Kitt May 27 at 6:57
  • It says: E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable) E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it? – Space May 27 at 7:03
  • That means that another process is running in parallel. You’ll have to wait for the lock to be released; then apt install should work. – Stephen Kitt May 27 at 8:55
  • Its Working now – Space Jun 5 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.