0

OS: Manjaro Linux x86_64 DE: GNOME / : Samsung SSD 850 evo 120GB

I recently restored my OS using a Timeshift backup. After completion, my disk got full with only 4GB of free space.

Before the backup, my used space was only 60GB. Now something just filled up my disk with an addition of 40GB.

I checked my disk usage with baobab(of course with sudo), but the stats didn't show that 40GB filled up storage.

Later I tried xdiskusage, I can say that it somewhat helped me find that space eater but was not helpful either. It simply says "(permission denied)" 40.08G. Attached image for reference:
enter image description here

Here's my df. It's the /dev/sda3 enter image description here

I used the find command sudo find . -size +40Gto filter out files greater than 40GB in file size, but nothing showed up.

I need to locate this space.

  • upvote for a well written post ..... does Timeshift store some type of a backup? – jsotola May 26 at 20:26
  • go to filesystem root and try du -sxk ./* |sort -n then dig into subdirectory which indicate big size. – dominix May 26 at 21:56
  • @jsotola I don't think timeshift did store some data on the root. It just uses rsync for add, delete and overwrite files. And also my Timeshift backups are located in a separate drive. So I have no idea what filled up that space. – Vishnu Raghav B May 27 at 6:40
  • @dominix tried it, but I don't see anything suspicious. That ghost file/folder doesn't show up. Any other suggestion? – Vishnu Raghav B May 27 at 7:15
  • @VishnuRaghavB when files get deleted their inodes still use space. this space is reclaimed only after the death of the process that deleted them. if there is a old living process keeping deleted files it may still display high disk space usage. in that case it may disappear after a reboot. – dominix May 27 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.