0

I have a computer with two SSDs, one with Windows 10 and another with Arch, freshly installed.

When I boot up and get to the Grub menu, the only options available are for Arch and Advanced Setup for Arch. No Windows 10.

When I select Arch, log in as root, and run fdisk -l, here's the output.

enter image description here

4
  • 1
    run update-grub
    – jsotola
    May 26 '19 at 20:17
  • Also with mounting the EFI and Windows system partition and running os-prober. More here wiki.archlinux.org/index.php/…
    – Biswapriyo
    May 26 '19 at 20:28
  • @jsotola I ran ‘sudo update-grub’ but got “command not found” as output.
    – Username
    May 26 '19 at 23:10
  • @Biswapriyo I installed ‘os-prober’ and ran ‘os-prober’ but got no output
    – Username
    May 26 '19 at 23:13
1

Try mounting the Windows partition and running sudo grub-mkconfig -o <path-to-grub.cfg> now that you have os-prober installed. On my system the path is /boot/grub/grub.cfg.

2
  • What code should I run to mount the Windows partition?
    – Username
    May 27 '19 at 19:13
  • 1
    @Username I would try sudo mount <device> /mnt, where <device> is the partition. If the Samsung 860 in the screenshot is the SSD with Windows, for example, the device would be /dev/sdd1.
    – antone
    May 27 '19 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.