0

I can't enable tmux feature on byobu terminal or on any terminal.

I run echo $TERM and i get

screen-256color

When i run tmux i get this:

sessions should be nested with care, unset $TMUX to force

tmux ls

1: 1 windows (created Sun May 26 20:01:01 2019) [80x23] (attached)

For xfce terminal with out tmux

xterm-256color

When i execute

echo $TERM 

I get this:

screen

And i can use the tmux feature CTL-b : only when i command the tmux

I run the command:

byobu-select-backend

And i select the tmux, but nothing

Config for byobu:

set -g mode-mouse on
set-option -g history-limit 2000000
set -g default-shell /usr/bin/zsh
set -g default-command /usr/bin/zsh
  • Not sure what you are trying to accomplish. In your first example, you are already in a TMUX session. That is what sessions should be nested with care is referring to. You CAN start a new tmux process under an existing one, but its not to be trifled with until you thoroughly understand TMUX and know what difficulties can arise. – 0xSheepdog May 29 at 17:49
  • Sorry, i don't know that Byobu don't use the tmux setting and that it have it own. – pioupiou Jun 9 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.