0

After a recent update, when I now log in to my system, my audio volume control suddenly goes to 100% and nearly deafens me. This appears to be something to do with (I guess) systemd changing the volume when I log in, but I do not know where to start looking to configure this.

I am happy for the volume to be set when I log in, I just want it set to 20% and not 100%.

Previously I was using alsactl for this, and even now running alsactl restore sets the volume back to my preferred 20%. So something is changing the volume when I log in, but it's not alsactl.

I am running a pretty plain Arch Linux install, with LightDM as display manager and AwesomeWM window manager. No other desktop environment to speak of.

There's nothing in ~/.config/systemd/ aside from loading an SSH agent, so I'm not quite sure where to start looking.

Does anyone know how to change the volume levels that systemd sets when you log in?

  • systemd services normally saved at /lib/systemd/system /etc/systemd/system directories, probably would be a good idea to look at them by systemctl list-unit-files | grep active then you will probably have an idea, which service is causing this issue. Look at this one, if you want to set a custom volume at bootup unix.stackexchange.com/q/364945/318405 – Rakib Fiha May 26 at 8:32
  • @RakibFiha: What service would I be looking for? None of the alsa ones seem to be enabled. The list-unit-files command is empty, nothing is active. There are enabled services but none of these mention alsa or anything sound-related. The other question is about creating a new service file to set the volume, but I apparently already have one of these as my volume is already changing, I just need to find it so that I can change its settings. – Malvineous May 26 at 8:40
0

Pulseaudio default configuration can reset levels to 100%
using Pulseaudio option 'flat volumes = yes'

to change this option:

echo 'flat-volumes = 0' >> ~/.config/pulse/daemon.conf

then re-start pulseaudio:

systemctl --user restart pulseaudio


for further information on this see man pulse-daemon.conf

  • Very interesting! Unfortunately I don't have Pulseaudio installed so is something else in my case. – Malvineous Jun 5 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.