1

I installed Debian 9 on my acer aspire 7 (A715-72G-75XG) laptop. However the network-manager does not detect wi-fi. Those are the outputs of a few commands:

$iwlist wlan0 scan
 wlan0     Interface doesn't support scanning.


lspci -knn | grep -i net
 00:14.3 Network controller [0280]: Intel Corporation Device        
[8086:a370] (rev 10)
 06:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.                                          
 RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
 [10ec:8168]                                      (rev 12)
      Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express 
Gigabit Ethernet Controller [1025:125e]

I have no idea what to do.

1 Answer 1

0

You need to install the linux-image and the firmware-iwlwifi (non-free) from backports.

add the following line to your /etc/apt/sources.list:

deb http://deb.debian.org/debian stretch-backports main contrib non-free

Then :

sudo apt update
sudo apt -t stretch-backports linux-image-4.19.0-0.bpo.5-amd64 firmware-iwlwifi
sudo reboot

Intel Dual Band Wireless-AC 9560

Intel® Wireless-AC 9560 : A kernel version 4.14+ is required.

PCI-IDS Device 8086:a370 : Name: Wireless-AC 9560 [Jefferson Peak]

6
  • I'm assuming you meant sudo apt -t stretch-backports install linux-image-amd64 firmware-iwlwifi ? In that case I get The following packages have unmet dependencies: linux-image-amd64 : Depends: linux-image-4.19.0-0.bpo.5-amd64 but it is not installable E: Unable to correct problems, you have held broken packages. I was able to install firmware-iwlwifi though, but it still doesn't detect wifi.. May 26, 2019 at 8:12
  • @RUBENGONÇALOMOROUÇO sudo apt -t stretch-backports install linux-image-4.19.0-0.bpo.5-amd64 , the kernel should be upgraded.
    – GAD3R
    May 26, 2019 at 10:37
  • it worked.. I'd like however to understand why was it necessary to install that other linux image. And also since it's a "backport" is it safe to use? Does it still receive security updates? May 26, 2019 at 12:11
  • @RUBENGONÇALOMOROUÇO A kernel version 4.14+ is required. As mentioned in the intel website (last link in my answer).
    – GAD3R
    May 26, 2019 at 12:26
  • oh I see. Just one more thing, how/where did you see what wireless my computer uses? May 26, 2019 at 12:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .