1

I am about to try and install the git package. In Synaptic, in the dependencies tab, it writes:

  • Breaks: bash-completion (<1:1.9-1)
  • Breaks: bash-completion [italicized]

I have the latest version of bash-completion offered by the repository installed (version 1:2.8-1ubuntu1).

I have read that git comes with some adapted auto-completion features, and I guess that this feature won't actually prevent completion to work in bash, right?

Also, the apt-get -s install git command doesn't output anything regarding the bash-completion package.

So my questions are:

  • Since I already have the latest version of the bash-completion package installed, what will happen to it upon the particular case of installing git?
  • What does the second line in italic mean in this particular context? How are the two lines different and not merged in a single 'Breaks: bash-completion' line?

Edit (additional information)

  • I have Linux Mint 19.1 (Ubuntu 18.04 base)
  • The repository offers git 1:2.17.1-1ubuntu0.4
  • What version of Ubuntu or derivative do you have? What exact version of git are you about to install? – Gilles May 25 at 15:54
3

You're seeing this Synaptic bug, which causes it to misparse “Breaks” dependencies. The two packages aren't actually incompatible.

You should be able to install git with some other tool, for example sudo apt-get install git in a terminal. It won't have any impact on the bash-completion package. I can confirm that there's no problem installing the git and bash-completion packages together at least on Ubuntu 16.04 and 18.04, and that does allow bash to complete git commands intelligently.


The git package is incompatible with an old version of the bash-completion package, so it declares a dependency Breaks: bash-completion (<< 1:1.90-1), meaning that this git package is incompatible with any version of bash-completion that's older than 1:1.90-1. This is an ancient version that is not present in any currently-supported version of Ubuntu: the oldest supported version (xenial) has 1:2.1-4.2ubuntu1. The reason for the incompatibility is that the git package provides its own script file for bash completion and the structure of bash completion scripts was different in older versions of bash-completion.

  • I see... Thanks for the reply! – The Quark May 26 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.