1

I configured OpenWrt to send syslog to a remote system. This has been working nicely for a long time, however I was missing logs from nginx.

nginx on OpenWrt does not support logging to syslog, so I used logger through tail to send the log entries to syslog, which then forwards them.

root@OpenWrt:/tmp/log/nginx# (tail -1 -F access.log | logger & tail -1 -F error.log | logger )&

It's mostly working great... except something is truncating the lines after 519 characters and inserting "[truncated]".

E.g.,

May 23 17:01:13 openwrt.lan root: [truncated] 10.11.12.13 - - [23/May/2019:17:01:13 -0400] "GET ...

I can't see anything in the documentation for busybox or OpenWrt that they should do this. I also don't see any indication that OpenWrt's syslog has done this before, but a grep of the busybox source code makes me think that this is likely not busybox doing it.

Is this OpenWrt syslog truncating? How can it be configured or stopped?

0

you must set Maximum length of input and History Size in menuconfig of openwrt source before compile

from this guide :

make menuconfig > Base system > busybox > Customize busybox options (set y for this) > Busybox Library Tuning > (set)Maximum length of input / History Size

for clear explian in this section :

http://uupload.ir/files/26cc_screenshot_20190614_130741.png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.