I have Samsung SSD 970 EVO Plus NVMe M.2 500GB mounted on the motherboard and it works fine, but when I open for example gnome-disks or parted to get more info about disk, system doesn't recognise model of the disk. SMART data & Self-Tests are also disabled.

This only happens on the M.2 disk. Normal SSD works fine.

enter image description here

Is there any kernel option or system configuration that can cause this?

I have linux-4.19.44-gentoo kernel.

  • 2
    From your screenshot (no model on the nvme drive) this may be related
    – bu5hman
    May 24 '19 at 15:03
  • @bu5hman It is probably related. But on Debian I can see model of the disk however SMART is still disabled.
    – BlueManCZ
    May 24 '19 at 15:19

SMART was originally an extension of ATA. It seems most tools now still only support (S)ATA because of that. Comparison of S.M.A.R.T. tools.

As for model detection, I'm guessing the problem comes from the same direction. Probably lspci still prints the correct device type. For instance on my system:

$ sudo lspci -kv
04:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM951/PM951 (rev 01) (prog-if 02 [NVM Express])
        Subsystem: Samsung Electronics Co Ltd NVMe SSD Controller SM951/PM951
        Flags: bus master, fast devsel, latency 0, IRQ 16, NUMA node 0
        Memory at dfa10000 (64-bit, non-prefetchable) [size=16K]
        I/O ports at d000 [size=256]
        Expansion ROM at dfa00000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/8 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [b0] MSI-X: Enable+ Count=9 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Device Serial Number 00-00-00-00-00-00-00-00
        Capabilities: [158] Power Budgeting <?>
        Capabilities: [168] #19
        Capabilities: [188] Latency Tolerance Reporting
        Capabilities: [190] L1 PM Substates
        Kernel driver in use: nvme
  • Thank you for info. You are right. lspci recognizes device type correctly as well as cat /sys/block/nvme0n1/device/model
    – BlueManCZ
    May 25 '19 at 9:52

As per Samsung's Drive Support FAQ:

  1. BIOS may fail to support the SSD if it is outdated. Please update the BIOS to the latest version.
  2. When there is a problem with the port, BIOS may fail to detect the SSD. Connect the SSD in a different M.2 slot if you have one, and try again.

Samsung also has a Facebook page for their SSDs, and you may get a quick response by posting there.

  • Bios recognizes model of SSD correctly. Problem must be somewhere in kernel modules or system side. Thank you for advice about Facebook, I can try ask there.
    – BlueManCZ
    May 24 '19 at 15:47

I just noticed that in the newer version of gnome-disks the model is already displayed correctly.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.