18

How to reset Xfce session?

When I start Xfce4, it always opens 2 windows of Evince, Emacs and one terminal emulator. I remember I used this configuration once a week ago, but now it starts every time after logging in. How can I make Xfce4 start cleanly with no applications?

2 Answers 2

24

This question is answered in Xfce wiki, subsection Some of my applications are always started when I login:

There are two possible reasons why the application is started: It is saved in the last session or it is listed in the auto started applications. Follow 1 of the two steps below to get rid of the applications.

  • Start the xfce4-autostart-editor and remove the application(s). You can also manually delete those files in ~/Desktop/Autostart and ~/.config/autostart.

  • Most of the time closing all the applications and save your session when you logout is sufficient. If this doesn't work, remove the content of the ~/.cache/sessions/ directory when you're not logged in. And if you don't want xfce remember every session you should turn off (uncheck) “Automatically save session on logout” in Settings Manager → Sessions and Startup (tab General)

Run this:

rm -fr ~/.cache/sessions/*

and Xfce should starts cleanly.

Also, you might need to clear the entire .cache directory if the above doesn't fix the issues:

rm -fr ~/.cache
4
  • You meant rm -rf ... right.
    – d_rail
    Jul 15, 2014 at 23:36
  • 2
    I was able to fix a lot of XFCE4 problems by running rm -fr ~/.cache.
    – Geremia
    Aug 24, 2016 at 21:06
  • 1
    Pay attention that the cache folder may be another folder that ~/.cache it's defined by $XDG_CACHE_HOME Feb 6, 2018 at 10:08
  • I would not casually suggest to rm ~/.cache. Lots of other app may depend on subdirs in /cache, so the user may break a lot of things that have nothing to do with the issue.
    – Francky_V
    Dec 25, 2020 at 19:52
7

Using the GUI seems to work as it should, at least in my version of Xfce (4.10).

In Xfce Menu go to 'Session and Startup'

enter image description here

And there, under Sesion/'Clear saved sessions':

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.