1

On programs that run in "fullscreen" mode, when I change the "fullscreen" resolution to something that is lower than what my desktop resolution is, I can scroll past the edges of the program by moving my mouse to the edge of the screen and see my desktop. This is really buggy and actually crashed my system, on top of being incredibly annoying.

How do you disable this? I don't even know what it is called, and I can't find ANYTHING except for this, really, unanswered question from 2003: https://www.linuxquestions.org/questions/linux-software-2/disabling-virtual-screen-mouse-scrolling-in-x-111237/

If anybody wants to see an example, then you can probably do it yourself by installing SuperTux 2, changing the fullscreen resolution to something like 640x480, then checking the fullscreen box, and moving your mouse to the edge of the screen.

2
+25

Partial answer:

The reason is that originally, the framebuffer size of the X server was fixed. The reason is that X applications may have asked the X server for the "screen" (framebuffer) size, and if now the X server changes it behind their back, they'll assume a wrong size.

So changing the resolution (via changing the modeline, e.g. with Ctrl-Plus and Ctrl-Minus) was implemented as keeping the framebuffer the same size, and offering a viewport into the framebuffer. And that viewport would automatically scroll.

There's not really a way to "disable" it. With modern X, you can use xrandr to change the framebuffer size as well (and I guess you could bind that to hot keys). But applications could still misbehave if they don't expect that, and don't support the RANDR extension.

Another option is to never run an application fullscreen, but instead always run it in a window, resize that window as necessary, and possibly convince your WM to render this window without a border. Might be a bit difficult to set up.

It's been ages since I played SuperTux, and it's quite old, so it's possible there's no way to make it work "properly" without changing it's source code.

  • So, is this an issue with X or the source code of the game being written improperly? If it's the game, then I can submit a bug report, but if it's an oversight in X, then this is ridiculous.. – SeanRamey Jun 19 at 0:11
  • The "oversight" in X has been fixed by the RANDR extension (it wasn't really an oversight, or people being too stupid, because things worked differently back then), but applications need to react to it. I guess you can submit a bug report, but I'm not sure that anyone will put in the effort to fix this quite old game - if you urgently need it, you may have to fix it yourself. – dirkt Jun 19 at 8:07
1

I think ArandR can help you with this. Heres my demo:

This is my normal desktop working properly, DP-1 will be the subject of this demo. Normal desktop working properly

Here I opened SuperTux2. SuperTux2 appears as fullscreen on my machine but this is how it appears to my screenshot tool. SuperTux2 Fullscreen

This is what clicking outside of SuperTux2 did to my desktop. Broken Desktop

With ArandR we can reset the resolution of the desktop. Simply clicking the checkbox on the top left will set it back to my original configuration. ArandR with highlighted checkbox

Viola! We are back, everything is normal again. ArandR turns the desktop to normal resolution

You could configure this manually in the terminal with XrandR, but I think that would be a lot more effort in this case.

I should also point out that (good) window managers should handle this sort of resolution change without crashing. You may want to upgrade your window manager if a resolution change is crashing your machine.

1

It seems you'll need to either change your or reconfigure your window manager.

A bit of info leading me to this conclusion...

With the Xfce DE, my window manager is Xfwm4. I tested by installing and running SuperTux2 as you suggested, and I didn't encounter the problem you're having.

Then, looking at the problem from the other direction - that is, trying to figure out how I could make my system do what yours does - I found the following post that clearly indicates that the window manager is at the crux of the issue... Looking for Desktop Environment to spread window over several screens

  • I'm using Antergos with KDE plasma. I haven't tried xfce, but i might and see if that helps. – SeanRamey Jun 3 at 17:53
0

I had the same issue when I switched from novaeu video driver to nvidia-304. Didn't have it before that.

I didnt understand what the screenshots above where showing, I have no checkbox in arandr.

I solved it by setting resolution before and after supertux2 in the desktop file execution command line:

xrandr --output VGA-0 --mode 640x480 && supertux2 && xrandr --output VGA-0 --mode 1920x1080

New contributor
Craig is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.