When I use ulimit -s to change the per-process stack size, it only lasts for that login; if I restart the setting is lost. How can I permanently change the maximum stack size on my system?

  • 2
    You need to be clearer about what you have tried and how you verify that it doesn't work. – phunehehe Oct 17 '12 at 13:10
  • I'm not posting an answer because I'm not sure what your question is, but it seems like limits.conf is what you need. – phunehehe Oct 17 '12 at 13:10
  • @phunehehe - But when i am changing limits.conf but values are not getting affected by process. so please provide me better solution. – Javed Mansuri Oct 20 '12 at 5:29
  • After changing limits.conf, you need to get the affected user log out and log in again. A simple reboot will be enough. – phunehehe Oct 21 '12 at 9:20
  • @phunehehe - Thanks for your valuable reply but i have also tried that when i reboot machine then also limits.conf not getting affected. – Javed Mansuri Oct 23 '12 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.